Dears, I’m installing dynare on matlab but all the matlab’ versions (once dynare is installed) are not able to read dynare files because the program give me back this answer : dynare\4.4.3\matlab\dynare_m " " Š not recognized as an internal or external command ,operable program or batch file, could you help me to solve this problem? Thank you very much.

Did you follow the procedure at [How to run a '.mod' file?)?

Yes, I did. That’s why I cannot understand which is the problem.

Please provide the full error message from Matlab

This is the complete answer:
Configuring Dynare …
[mex] Generalized QZ.
[mex] Sylvester equation solution.
[mex] Kronecker products.
[mex] Sparse kronecker products.
[mex] Local state space iteration (second order).
[mex] Bytecode evaluation.
[mex] k-order perturbation solver.
[mex] k-order solution simulation.
[mex] Quasi Monte-Carlo sequence (Sobol).
[mex] Markov Switching SBVAR.
" " C : \ dynare \ 4.4.3 \ matlab \ dynare_m " " Š not recognized as an internal or external command , operable program or batch file .
Thank you.

Could it be that your filename of the mod-file is not a valid Matlab function name? Does it contain non-standard letters?

No I don’t think so. Because before installing the new operating system few weeks ago, matlab worked and recognised all the dynare mod that I had; now it is happening something strange because with the same files it does not run.

Because I am puzzled by the

Which operating system are you using?

Sorry I would say Windows 8… Yes, this is exactly what I don’t understand!!

And what follow are the strings that matlab give me every time I open it without running anything. But again it is weird because I have not folders with these names

Warning: Name is nonexistent or not a directory: \Users\tzha\ZhaData\Git\TZcode\MatlabFiles

In path at 110
In startup at 32
In matlabrc at 188
Warning: Name is nonexistent or not a directory: \Users\tzha\ZhaData\Git\TZcode\MatlabFiles\MSV
In path at 110
In startup at 33
In matlabrc at 188

Please try cleaning your matlab path. Please delete all paths where you get error messages and all paths related to Dynare. Then reset the path to Dynare’s Matlab folder.

I can delete only the path related to dynare

I did, but again there is the same problem

Have you tried deleting and then reinstalling Dynare?

Yes, I’ve tried

What does Matlab return when you enter:


so for the first code, it returns C:\dynare\4.4.3\matlab\dynare.m, for the second one ‘dynare_m.exe’ not found. Perhaps this shoul be the problem

Yes, that is the problem. Could it be that your antivirus program or something similar prevents you from unpacking the exe-file?

So I’ll try to deactivate my antivirus and reinstall dynare, because I really don’t know

I did all the installation process for both matlab and dynare without antivirus, but again it doesn’t work. I really do not understand why