Installation problems of 4.6.0 on macOS

Hi, I had experienced an error when I try to install 4.6 on macOS 10.15.3, I tried several times, all failed, is it a bug?

What is the error you are experiencing?

I encounter an error message at the last step," Installation failed, please contact the software developer for help"(translate from Chinese), and after (failed) installation, I found a 4.6 folder under the “Application/Dynare” folder, and the older version of dynare is deleted from the system.

I just tested the dynare 4.6 with the example1/2/3, it works, but with example1_reporting, it failed with message "Unable to access method ‘getRange’ in class ‘report_series’ ". So I think it actually successfully installed in some extend, and returned a partial wrong ‘error message’ and it does delete the older version automatically.

Here is the install.log under the 4.6 folder:
"+ rm -f /Applications/Dynare/4.6.0/dummy
++ curl -s -m 4 www.google.com
+[[ -z ‘’ ]]
+echo ‘No internet connection found’
No internet connection found
+exit 1
"
Thanks for your reply.

@HoutanBastani Could you maybe have a look?

Well, from the log message it seems that you were not connected to the internet continuously during the installation process. You can delete the /Applications/Dynare/4.6.0 folder and try again, ensuring you have a solid internet connection. If you don’t have a solid internet connection, you can customize the installation to unchecking the use_dll component that installs GCC on your system (this is the part of the installation that requires an internet connection). NB: doing this would make it impossible to use the use_dll option to the model block.

Hmmm, actually, thinking about it some more, is there a chance that www.google.com is blocked where you are? This is the site we connect to to test whether you have an active internet connection, but if it’s blocked where you are, perhaps that needs to change…

Hi there, I’m also experiencing difficulty installing Dynare 4.6.0 on my Mac. I’ve already installed the latest version of Xcode and Homebrew. and the install.log stuck at:
==> Tapping homebrew/core
Cloning into’/Applications/Dynare/4.6.0/.brew/Library/Taps/homebrew/homebrew-core’…
It’s been like this for about half an hour, I don’t know whether I should be shutting it down.
Also if I’m wandering if I can customize the installation on Mac, if so, where can I choose to unchecking the use_dll component.

Thanks a lot

Hi @Angie, yes you can unselect the option to install the compiler. The instructions to do so are in the Introduction text on the first screen of the installer.

You can choose not to install GCC by choosing Customize from the Installation Type screen and deselecting GCC compiler. If you already have gcc-9 installed under /usr/local, you can forgo the installation of GCC here as Dynare will find your system compiler when you use use_dll.

Otherwise, to debug your installation, please post the install.log file you referenced and I’ll have a look.

install.log (52.3 KB)
This is the install.log
I’m using a VPN to get access to Google, it’s a bit slow but the internet is stable. I’m not sure whether this install.log shows the installation is still processing ~

That phase of the installation requires downloading about 400 MB of data. If you have a slow internet connection, this could explain why it’s taking a long time. Is https://github.com blocked where you are as well? With the next release of the macOS installer, we will no longer have to access google (which was just done to quickly test internet connectivity). However, we cannot get around accessing https://github.com. If you can access https://github.com without the VPN, the installation should go much more quickly…

okey, I understand, thanks a lot~

Yes, due to the compliance of the law, ‘www.google.com’ is blocked here, if it is the internet connection that makes such error, is it possible to change the internet verification link in some region, maybe ‘www.dynare.org’ can be a candidate link, and I can access https://github.com/ without VPN. By the way, if internet connection verification caused an install failure, why there is no such error in an older version like 4.5.7.

Thanks for your reply.

Old Dynare versions did not install the GCC compiler, so there was no internet connection necessary.

1 Like

@lnsongxf it’s good to know you can access GitHub without a VPN. Thanks. The necessary changes have been made to the macOS installer and will be included in the bug fix release.

1 Like

@lnsongxf @Angie please try the installer for Dynare 4.6.1 and tell me if you encounter any problems: https://www.dynare.org/release/macos/dynare-4.6.1.pkg

I tried 4.6.1, it stuck at the last step for a long time, and return a failure message finally. I think it is the same problem as 4.6.0, is it possible to have an install package that GCC compiler build-in, and let the user choose which one to download.

This error only occurs on macOS platform, I also install a Windows version Dynare on Parallels Desktop on the same Macbook Pro, the installation is OK under the same internet connection situation.

I will try again, and let you know if I get more information.

Thank for all of your hard work.

Can you attach the install.log file in the /Applications/Dynare/4.6.1 directory? That will help me debug it.

It’s not the same problem as 4.6.0 as before it was getting stuck trying to connect to www.google.com. We are no longer doing that.

The installation strategies on macOS and Windows are different because the operating systems are different. The Windows installer does not download anything. The macOS installer downloads and installs Xcode Command Line Tools, Homebrew, Git, and GCC. This is several GB of data.

install.log (138.3 KB)
This is the install.log, hope it is helpful.
Thank you.

The installation was proceeding correctly but ends because a file could not be downloaded.

The error comes from the command:

curl -# -L https://github.com/Homebrew/brew/tarball/master | tar xz -m --strip 1 -C /Applications/Dynare/4.6.1/.brew

which is downloading and untaring a tarball provided by Homebrew from github.com. The download size is only 1.7M, but the download ends with the following error after downloading 27.1% of the tarball:

curl: (56) LibreSSL SSL_read: SSL_ERROR_SYSCALL, errno 54
Library/Homebrew/test/patching_spec.rb: truncated gzip input

This indicates a network connectivity problem.

If you cannot fix this problem, you have another option. You can chose not to install GCC via the Dynare installer (when on the Installation Type section of the installer, choose Customize then deselect GCC). After installing Dynare, you can install Homebrew and GCC on your system. The commands to do this (which you would type into Terminal.app) would be:

/bin/bash -c "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install.sh)"
brew install gcc

Dynare will find the system version of GCC if there’s no version in the installation folder.

OK, get it, thanks for your good work.

1 Like

Hi,
I am trying to install 4.6.0 (also tried 4.6.1) on macOS 10.15.3, just like Insongxf. I definitely have a stable internet connection and can access Google, but nonetheless the installation always fails asking me to contact the developer. I also end up having the Dynare folder in my Applications Folder. Could you let me know how to fix this? Or where would I find the install-log to find out what went wrong? Thank you!