Installation failure with Dynare 4.6.4

Hello Dynare Forum,

I am having trouble installing Dynare 4.6.4. I am following the instruction of the quick start but failed several times. I have tried deleting the dynare 4.6.4 folder and reinstall several times as suggested by other posts, but it does not work. I checked the error in my install.log. It says “Error: Failed to download resource “gmp””. I googled but found nothing. This is my install.log file. I would appreciate your help very much.
install.log (252.2 KB)

Your OS seems to be Catalina (10.15), Dynare 4.6.4 only supports macOS 11 (Big Sur).

Thank you for your reply. I checked my macOS. It is Big Sur
Screenshot 2021-07-21 at 21.03.50

Then it is strange. Homebrew tries to install GMP for Catalina. Did you use the macOS package provided on the Dynare homepage?
@sebastien Do you have an idea what might be going on?

Yes. I used the macOS package.

I don’t know what’s going on here. For some reason, Homebrew tries to download the Catalina version of the GMP binary, which does not exist.

Maybe there is some old system-wide Homebrew installation on this system, that conflicts with Dynare installer?

Thank you for the reply. Should I uninstall the Homebrew and reinstall it again?

If you have a system-wide Homebrew installation, then you could uninstall it, then install Dynare, and then finally reinstall Homebrew system-wide (if you need it for your own purposes, because Dynare uses its own local copy of Homebrew)

Thank you. I will give it a try and let you know if it works

Hello @sebastien, I have tried uninstall Homebrew and install Dynare. But installation failure with the same error message

install.log (247.6 KB)

Unfortunately I have no clue at this point… :disappointed:

Chiming in with two more Big Sur(11.5.1)/M1 chip users here with the same issue:

curl: (22) The requested URL returned error: 403 Forbidden
Error: Failed to download resource “gmp”
Download failed:

It’s actually interesting because brew knows we’re on Big Sur:
% brew config | grep macOS
macOS: 11.5.1-arm64

But % brew install gmp worked.

The install still failed with the same gmp install error though. I see from the logs that we’re installing gcc so I installed that and the install still tried to install GCC and GMP, and failed with the same gmp error.

Is this all happening in a container?

Maybe it’s because of M1. Have you tried getting support at Homebrew? Also, maybe Compile from source on Mac M1 Apple Silicon architecture (#1780) · Issues · Dynare / dynare · GitLab provides some clues. @wmutschl Have you experienced anything like this?

No I have not. Could you try to install Dynare from source? Following this video:

Does this work for you? Particularly, be careful with the arch -x86_64 prefix!

I also have the problem Error: Failed to download resource “gmp” when install Dynare on my macOS Big Sur version 11.5.1 (not M1 cheap)
Could you please teach me how to solve this problem?Thank you very much!

install.log (256.0 KB)

We are at a loss what is going on. I opened a discussion at

We received the answer that Bintray has shut down. You need to update the copy of brew with

brew update

in order to download from Homebrew’s new bottle host (GitHub packages). @Ashley Could you please try that and report back.

no Prob.
thank you for your reply!

I tried uninstall homebrew and install dynare as @sebastien suggested but failed again.

Then I reinstall homebrew and ran brew update.
Here is the result.

==> Installation successful!

==> Homebrew has enabled anonymous aggregate formulae and cask analytics.
Read the analytics documentation (and how to opt-out) here:
No analytics data has been sent yet (or will be during this `install` run).

==> Homebrew is run entirely by unpaid volunteers. Please consider donating:

==> Next steps:
- Run `brew help` to get started
- Further documentation:
ashley@maomaoyudarendeMacBook-Pro ~ % brew update
Already up-to-date.
ashley@maomaoyudarendeMacBook-Pro ~ % 

After this, I installed dynare but failed.

And here is my new install.log showing the same problem we aimed to solve. @jpfeifer

curl: (22) The requested URL returned error: 403 Forbidden
Error: Failed to download resource "gmp"
Download failed:

install.log (260.3 KB)