Error While Installing Dynare 4.6.3 Mac OS Big Sur

Hello everyone,

I had a problem while installing version 4.6.3 in my Mac OS Big Sur:

Attached the install log fileinstall.log (186.7 KB)

p.s. I’ve tried the method exposed in other topics, that’s why I’m still reposting it

As the error says:

Error: You have not agreed to the Xcode license. Please resolve this by running:
sudo xcodebuild -license accept

Did you try to install Dynare via Homebrew or via Only the latter should work.


I had the same error as Joao @jp.mainente posted while installing Dynare 4.6.3 onto Mac OS Big Sur (M1).

I followed Johannes’ advice @jpfeifer and ran: sudo xcodebuild -license accept.

Now I have new installation error. I attach the log file here. Any help would be appreciated. Thank you for your time!

install.log (583.8 KB)

@Lina_GU Homebrew does not work as of right now. Please install the application from the Dynare homepage as suggested in my last post.

@jpfeifer Thanks! I did install the application from the Dynare homepage. I downloaded the software from and installed it following the instructions. I encountered the error notice as follows: Screen Shot 2020-12-15 at 12.25.04 PM

The install.log is attached here for your reference.
install.log (584.5 KB)

Maybe @HoutanBastani can help. The log suggests a failure in the testsuite…

From the log it seems as though the Dynare Installation package needs to be updated to work with Homebrew + macOS 11. The log shows that gmp is being built from source:

Warning: Building gmp from source as the bottle needs:
- HOMEBREW_CELLAR: any (yours is /Applications/Dynare/4.6.3/.brew/Cellar)
- HOMEBREW_PREFIX: /usr/local (yours is /Applications/Dynare/4.6.3/.brew)
- HOMEBREW_REPOSITORY: /usr/local/Homebrew (yours is /Applications/Dynare/4.6.3/.brew)

whereas the GCC dependencies were bottled for Homebrew + macOS <= 10.15.

The log implies that having a brew directory in the Dynare folder necessitates recompilation of gmp (and perhaps other packages), but this conclusion will require more investigation.

You can probably install without GCC support until this is fixed.

I procided as suggested by @jpfeifer and contrary to @Lina_GU, I was able to install normally

Thank you @jpfeifer! And I’m attaching the installation log in case it helps the investigation.

install.log (213.3 KB)

Hello! Thank you so much for this super helpful thread! I am also unable to install Dynare with MacBigSur! I think I am having the same problem as @Lina_GU. How should I proceed? I am attaching my log file for referenceinstall.log (208.6 KB)

Actually, what should really be done in this case is to manually reinstall the Command Line Tools (CLT), via the Apple website. For some reason, the Dynare installer thinks the CLT are there, while they are not fully installed. This will solve the git problem.

hello , could you teach me how to find the install.log in my macOS Big Sur Version11.5.1 ? Thank you very much!
I only find package_script_service_2021-08-16-164557_maomaoyudarendeMacBook-Pro.cpu_resource.diag in my DiagnosticReports and Console. There’s no install.log after the installation fails.


Hi all,

I’m reopening this, because I’m having trouble installing Dynare 4.6.4 on my new mac (big sur 11.6, M1, 2020). please see atteched the install log file. I tried the all the suggestions on this forum again, but without success.

I’ve even tried installing the 4.6.3 version.

Dynare 4.6.4: install.log (251.7 KB)

Dynare 4.6.3: install.log (251.5 KB)

See Failure to install Dynare 4.6.4 using the installer package on macOS BigSur 11.4