? Error using ==> dynare at 126 DYNARE: preprocessing fail


I tried to replicate Christiano and Eichenbaum(1992)'s model. After finishing writing source codes in the Editor, I created Mod file named “divi_chris” to represent a case of divisible labor. After that, I tried to run program through typing command “dynare divi_chris”. A received message is

Starting Dynare (version 4.1.2).
Starting preprocessing of the model file …
ERROR: divi_chris.mod:4.38-41: syntax error, unexpected NOBS

??? Error using ==> dynare at 126
DYNARE: preprocessing failed

I had no idea what was going on. Therefore, could you have any suggestion about our work? Any comment would be very appreciated.

Thank you

I also attach two related files

  1. divisble_christiano eichenbaum R02.doc
    divisible_christiano eichenbaum R02.doc (148 KB)

  2. divi_chris.mod
    divi_chris.mod (2.35 KB)

I am not quite sure whether my windows version has any effect to the error. But just to notify you that my version is 32 bit.


I have this problem as well. Does anybody know the resolution?

Nobs is a reserved command. Call the variable n_obs for example. Moreover, there are several brackets wrong in line 59

Hi jpfeifer,

Thank you very much for your kindness. But after I corrected my work as your comment. I still have some several problems which are shown as follows

??? Error using ==> dynare_solve at 82
exiting …

Error in ==> steady_ at 124
[oo_.steady_state,check] = dynare_solve([M_.fname ‘_static’],…

Error in ==> steady at 52

Error in ==> divi_chris at 198

Error in ==> dynare at 132
evalin(‘base’,fname) ;

I still have no idea. If you could help me again, it would have been very appreciated.
divi_chris_R02.mod (2.36 KB)

You did not specify the steady state value for A. The SS value for Z in the log specification cannot be 0 (log(0)=-Inf), but must be 1. Note also that you should provide initial values for all (!) endogenous variables.