Dynare installation fails with MacOs Catalina and Matlab_R2020a

Apologies. See new screenshot attached

Type echo $PATH and hit enter. Then type /usr/bin/git --version, hit enter, and send all of the output

It seems like there’s a problem with your Command Line Tools installation. Dynare needs this to install support for use_dll in Dynare .mod files.

Do you have Xcode installed on your system or only Command Line Tools? Whatever you have, I’d try uninstalling it and reinstalling it.

Thank you. Will do.
Can you advise on how to do this?

Mattia

Did you install Xcode or did you install Command Line Tools?

To be honest, I don’t know. And I don’t know how to check which one I have installed (if any), sorry…

Do you have Xcode.app in the your Applications folder?

No, I don’t have it.

Then you should be able to open Terminal.app and run

sudo rm -rf /Library/Developer/CommandLineTools

After this, run

xcode-select --install

After that is done installing, remove the folder /Applications/Dynare/4.6.1 and rerun the Dynare 4.6.1 installer. If that ends with an error again, post the new install.log file here.

1 Like

It works! Thanks so much Houtan!

Mattia

1 Like

Hi, I did all the steps above but instead of having “The installation failed” message, the installtion just froze at the last step.

If anyone can help it would be great because I kinda need to use dynare asap…

Thank you very much!!

Please post your
/Applications/Dynare/4.6.1/install.log

Continuing the discussion from Dynare installation fails with MacOs Catalina and Matlab_R2020a:

Hi,I have met the same problem as the user thanhnguyenvn98, I did all the steps above but the installation froze at the last step. Here is the install.log.
I look forward for your help cause I need to use Dynare ASAP…
Thank you very much !!

install.log (153.2 KB) Here is my install.log, my installation froze at the last step, could you give some help ,thanks a lot.

The message

RPC failed; curl 56 LibreSSL SSL_read: SSL_ERROR_SYSCALL, errno 54

suggests that your internet connection broke down. Try reinstalling.

Hi, As I am using Macbook air m1 and dynare 4.6.4 and I have already installed Xcode. Yet, it still fails. Here is my install.log. Thank you SO MUCH!!!
install.log (256.9 KB)

See

Hi, I’m also facing an issue with installation. I have OS Big Sur Version 11.5.2. I’ve tried a few Dynare versions 4.6.1 - 4.6.4, but I always get the same error message: The installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance. I’ve followed the steps for Xcode, and seek advice on how to proceed. My log file is attached. install.log (264.7 KB)
Thanks very much