Checksum file

I’m simulating a deterministic new-keynesian model.
Dynare return this kind of error:
" can’t open file filename/checksum"
I don’t know what the checksum file is, and so it’s impossible to understand the nature of the problem.
Can someone please give me an idea?
Thank you

That is a file created by Dynare to keep track whether the model has changed so the existing files do not need to be updated. It is used in the context of the


command line option, which is particularly useful when combined with the use_dll

The error message you report suggests that either you do not have the correct permissions for accessing/writing that file or that it is still open from a previous process. You should typically be able to exclude the latter by closing and reopening Matlab.

Thank you! Closing all the related documents now it’s working!

Dear Professor Pfeifer,
I tried to open and close the matlab instance but I got always the same error message. Is there any particular command that I should look at? Thank you

Sometimes the reason is that your total file path is too long. Have you tried using a folder closer to the root directory?

Now. It works. Thanks a lot… I added a loop for the determinacy plot and now it says:

Error in stochastic_solvers (line 214)
kstate = dr.kstate;

Error in resol (line 144)
[dr,info] = stochastic_solvers(dr,check_flag,M,options,oo);

Error in constantN_mu_shock (line 324)

Error in dynare (line 223)
evalin(‘base’,fname) ;

constantN.mod (8.0 KB)

Determinacy relies on a linearized stochastic equilibrium system (stoch_simul). But your are doing nonlinear perfect foresight simulations (simul).

Thank you… I will rewrite the model in a stochastic framework.

Dear all,

I am trying to run my model, nevertheless I am receiving the very same error message, namely:

Configuring Dynare …

[mex] Generalized QZ.

[mex] Sylvester equation solution.

[mex] Kronecker products.

[mex] Sparse kronecker products.

[mex] Local state space iteration (second order).

[mex] Bytecode evaluation.

[mex] k-order perturbation solver.

[mex] k-order solution simulation.

[mex] Quasi Monte-Carlo sequence (Sobol).

[mex] Markov Switching SBVAR.

Using 64-bit preprocessor

Starting Dynare (version 4.5.6).

Starting preprocessing of the model file …

Found 113 equation(s).

Evaluating expressions…done

Computing static model derivatives:

  • order 1

Computing dynamic model derivatives:

  • order 1

Processing outputs …

ERROR: Can’t open file Credit_and_Participation/checksum

I know the model has some imperfection and that I am forcing it to run but it should not give me such an error anyway.

Can anyone help me to understand where the problem is?


I double-checked the permissions for accessing/writing.

Credit_and_Participation.mod (36.0 KB)

Did you check the path length?

Yes. I tried to move the folder but it still returns me the same message

Does the message appear on the first run? Or when you run it a second time?

It appears everytime I try to run the code.
My full path is:

C:\Users\Marco Forti\Documents\PhD

Sorry for replying here, but the forum only allow me to edit 3 replies

That is very strange. What is the full path of your file?

Does that only happen on your machine? Or also on others?

It was a specific problem.

My solution was to format and re-install everything from the beginning. I don’t think such solution would work for anybody else, by the way this has been my solution.

Hi Professor Pfeifer,

I have been editing a mod file, and now this is the error I am getting, even when I close my Matlab and reopen. The path length is pretty short: C:\dynare\work.

I have been trying to fix other problems, so perhaps this is related to something more fundamental, but I’m wondering if there might be a simple issue this time.

Here is my recent version of my file. test2.mod (1.4 KB)

(Also thank you, your online guide has been very instructive!)

That is strange. Is there an application locking the file, e.g. a Cloud drive app like Dropbox or an antivirus program?