Using my own estimate of the mode and Hessian matrix


I’m trying to start a chain from a particular mode of my choice, and would also like the use my estimate of the Hessian matrix. The mode file I am using is a .mat file which contains two elements: xparam1 (with the mode) and hh (the hessian).

However, when I try to run the estimation command below


I get the following error message:

??? Output argument “info” (and maybe others) not assigned during call to “C:\Dynare\dynare_v3\matlab\DsgeLikelihood.m (DsgeLikelihood)”.

Error in ==> DsgeLikelihood at 5
global bayestopt_ exo_nbr dr_ estim_params_ Sigma_e_ options_ xparam1_test

Error in ==> initial_estimation_checks at 20
[fval,cost_flag,ys,trend_coeff,info] = DsgeLikelihood(xparam1,gend,data);

Error in ==> dynare_estimation at 253

Error in ==> LOWW_benchmark_5_estimate at 500

Error in ==> dynare at 26
evalin(‘base’,fname) ;

If I suppress the mode_file=… from the estimation options and set mode_ compute=1 then the estimation works fine.

Is there a way to load the mode that will be used to start the chain, and can I also load the Hessian used for the jumping distribution? The files I am using are attached.

Thank you so much for your help.

Kind regards,
Daniel Beltran
Federal Reserve Board (15 KB)

did you check whether the size of xparam1 you enter and the number of parameters dynare has been instructed to estimate are the same?
also check if the sequence of parameters that you entered in the xparam1 vector conforms to the sequence of parameters you defined in the estimated_params block.


Hi Reuben,

Thanks for your reply. The size of xparam1 is 31 x 1 and I am estimating 31 parameters. The order in which they are specified is also the same as in the estimate parameters block. The hessian (hh) matrix is 31 x 31.

The files I am using are attached as a zip to the first message I posted.

Kind regards,


you should go inside the code “initial_estimation_checks.m” and then in “DsgeLikelihood.m” (use a dbstop command) and then see what the error is. One possibility is that the initial mode_file you load could be outside the bounds of the priors.


Thanks for the tip, I’ll try that.