Unable to run a model with newer version of Dynare

I’m having issue to run the following replication code DMI_replication.zip (2.3 MB) due to incompatibility of Dynare version. The code was created by the authors with Dynare 4.3.1; when I run it with Dynare4.6.1, I get the following error: Too many input arguments.
I tried to modify the steady state file.
The initial steady state file is old_sigma3country_steadystate.m (667 Bytes) which I modified to have this new version
sigma3country_steadystate.m (1.3 KB). But when I run the model, I got an error stating that The steady state has NaNs or Inf.

What would be the necessary change to the steady state file in order to properly run the model with Dynare 4.6?

Thank you

Do you want to run the file with OccBin?

Yes. The occbin version is occbin_20130531 (included in the replication folder).

What I mean is: what is your ultimate goal? You are trying to upgrade to Dynare 4.6, but the OccBin version delivered in the package is not compatible with that version. At the same time, Dynare 4.6 does not come with its own implementation of OccBin…

I want to run the the model in Dynare 4.6.4 but was facing compatibility issue. I was able to solve the problem by updating the steady state file. However after running the stochastic simulation, I don’t get the Irfs even though I didn’t put the noprint option. Could you please help with that?


Sorry, but we don’t provide support for the OccBin package. I recollect that you have to plot the results yourself.

When I try to generate the irfs, I got the following error:
Error using eval
Must be a text scalar.
Error in solve_one_constraint (line 44)
eval([Mbase_.param_names(i_indx_,:),‘= M_.params(i_indx_);’]);

Error in runsim_eggtrade_potential (line 58)

Could you please help identify the potential source of that error?

As I wrote above

You can try GitHub - JohannesPfeifer/Occbin_update

It works. I was able to update the simulation file using the updated occbin package. Many thanks!

1 Like