''The steadystate file did not compute the steady state'' and resid(1) questions

Hi, I have trouble in compiling dynare .mod file and it’s my first time to deal with it so that I am frustrated…can anyone help me? :frowning:

The question I met is that the result of running dynare shows: ‘‘The steadystate file did not compute the steady state’’ with only one residual stays non-zero; it seems common, however, the steady state value did solve the equation which shows non-zero residual.

The equation that shows non-zero residual is: G + (tr_p + tr_i + tr_i + tr_e) = tax;
However, the steady state values are as follows G=-0.0693, tax-(tr_p+tr_i+tr_r+tr_e) =-0.0693 andY-(c_p+c_i+c_r+c_e)-del_k*(k_p+k_e)=-0.0693, which are derived from a matlab file whose parameters and steady state solution are the same as what in _steadystate.m file.

If the steady state value solve the equation listed in mod file, the residual of that equation will be zero, isn’t it?

I am so frustrated and I would be very glad to get any help or hint you can give me. :frowning:

As a first step, please see Residuals of SS equations in Bayesian estimation

Thanks so much for replying! But I am confusing what you mean “in the correct order”?


I have modified the _steadystate.m file to fit the form of NK_baseline_steady_state.m; however, I met another problem:

the amount of the equations whose residual stay non-zero of modified _steadystate.m is unequal to that of pre-modified _steadystate.m, it increases!

I wonder the reason why it happens. In fact, I just change the file’s name and copy my steady state formula into the “Enter model equations here” area, all the other parts stay unchanged.

I define some constants in pre-modified and modified _steadystate.m which are consists of parameters defined in .mod file in order to compute the steady state value easily, and these constants don’t exist in .mod file. Is it the reason?


By the way, the pre-modified _steadystate.m are compiled according to the _steadystate.m from Iacoviello(2013) Financial business cycles which works. Does the previous form of my _steadystate.m file cause this kind of error message?

Thanks for your replying. :slight_smile:

Here I try a different way to declare the steady state in which I add a steady_state_model; end; block and fill out all the formulas listed in the _steadystate.m file.

And unfortunately, it shows the same result that one of the residuals stay non-zero while the value of that equation is actually zero by computing by _steadystate.m file value.

I am confident of the steady state formula which I solve by hand, so I really need a help…:frowning:

If you think your steady state file is correct, then your model must be wrong. The values returned by the steady state file/steady_state_model-block are inconsistent with the entered equations.

Thank you for your replying.

I have solved this problem after I change my model setting!

I guess that the mistake happens may result from an inappropriate setting for defining a steady state Y in my old mod file: I define a Yss in my mod file, and let Yss equal to Y in the _steadystate.m file.

Leave a reference for someone who has the same problem with me! But I am not sure. :stuck_out_tongue_winking_eye: