Steady state convergence problems - tried everything

I’m having problems finding the steady state of my model. I managed to reduce the residuals of some equations, and even bring 7 out of 18 to hold exactly. However I can’t get dynare to find the steady state, I’ve tried the following:

  1. use the different solvers
  2. play with the starting values to progressively reduce the residuals
  3. derived some steady states manually
  4. used the program kindly posted by one of the users, called dynareFindSteadyState

However I get the following message when doing option 4:

no unique convergent solution
failed to compute steady state

Can anyone give me any tips, or indicate what is going wrong please?

I’m attaching the complete mod file below. It’s a small NK model a la’ Gali (2005), with ricardian and rule-of-thumb households. The economy is very small and forms part of a monetary union, though it does not affect it. The government sector is switched off for the moment to try and simplify it.

Many thanks
model_w.mod (2.39 KB)

Sorry, but could it be that you define pi as an endogenous variable, but it does not occur in any model equation?

Yes I forgot to remove pi as it was extra there. I’ve realised there is an equation which can be made redundant.

Many thanks