Steady state computation in estimation

Dear all,

I’m trying to estimate my model as attached, and get the following error message. But if I remove estimation function, the model is able to find a steady state and working. How should I address this? Appreciate any help.

“dynare_estimation_init:: The steady state at the initial parameters cannot be computed.
Error using print_info (line 83)
Impossible to find the steady state. Either the model doesn’t have a steady state, there are an infinity of steady states,
or the guess values are too far from the solution”

data2full.xlsx (17.5 KB)
model.mod (6.4 KB)



You need to move the
steady (maxit=20000, solve_algo=2);
before the estimation-command. That way, the estimation will use the options you set here for steady state computations.

Thank you professor jpfeifer. After the correction, I now encounter the following problems. How should I can address them? Thanks.

initial_estimation_checks:: The forecast error variance in the multivariate Kalman filter became singular.
initial_estimation_checks:: This is often a sign of stochastic singularity, but can also sometimes happen by chance
initial_estimation_checks:: for a particular combination of parameters and data realizations.
initial_estimation_checks:: If you think the latter is the case, you should try with different initial values for the estimated parameters.

ESTIMATION_CHECKS: There was an error in computing the likelihood for initial parameter values.
ESTIMATION_CHECKS: If this is not a problem with the setting of options (check the error message below),
ESTIMATION_CHECKS: you should try using the calibrated version of the model as starting values. To do
ESTIMATION_CHECKS: this, add an empty estimated_params_init-block with use_calibration option immediately before the estimation
ESTIMATION_CHECKS: command (and after the estimated_params-block so that it does not get overwritten):



As the error message says, there is stochastic singularity. See e.g. Estimation error with Dynare 4.5.3

Thank you professor Pfeifer. I have removed the linear combination between the observables, so no more singularity. But the problem now is “matrix not positive definite”, with error messages as below. I’m not sure how should I revise the initial values of parameters. Appreciate your guidance here. Thanks.

Matrix must be positive definite

(minus) the hessian matrix at the “mode” is not positive definite!
=> posterior variance of the estimated parameters are not positive.
You should try to change the initial values of the parameters using
the estimated_params_init block, or use another optimization routine.



Please provide the most recent version of the files

Hi Professor Pfeifer, here are the latest version of the files. Understand I estimate too many parameters with too few observations. Though adding observable variables requires more shocks and I’m struggling to figure out how to add more shocks. Deleting some parameters seem to work, but I still want to estimate as many parameters as possible. Appreciate any guidance. Thanks.

data2full2.xlsx (16.2 KB)
thesissmall2fullest.mod (5.5 KB)

  1. At a minimum, identification tells you that you cannot estimate ts with your observables.
  2. Use a different mode-finder. mode_compute=5 worked well. The mode-file is attached.
  3. The parameter that creates problems for the Hessian is tau. Try using a prior that pushes it away from the upper bound of 0.