Stability of recent dynare++ releases


I’ve noticed that the latest dynare++ releases - those that come as part of the whole dynare package - appear significantly less stable than the previous, standalone version I was using. In particular, I get the following error quite frequently (also on files on which the previous version ran ok):

[quote]This application has requested the Runtime to terminate it in an unusual way.
Please contact the application’s support team for more information. [/quote]

The error appears to be quite random and difficult to trap - we have training PCs that are meant to be exactly identical. I’ve tried dynare++ on the same model file on all four and got it to work on two PCs and crash on the remaining two…

Which leads me to wonder - are other people experiencing similar difficulties? Could it have something to do with the way the new binaries are being compiled?

Many thanks in advance

Hi Pawel,

this is an interesting and important feedback. We are going to see what we can do.

On your side, could you help by

  1. recompiling dynare++ from source (if OK, we will give you more detailed instructions)?
  2. contribute your training PCs to test a commonly agreed upon series of examples?

Maybe you can write directly to my email address (with copy to Sebastien) to continue this exchange.




Are you using the Dynare++ coming with Dynare 4.1.0 or 4.1.1 ?

The one coming with 4.1.0 suffers from known stability issues. You should use the one coming with 4.1.1 if not already the case.


Hi Michel and Sébastien

Thanks for your posts. I was using version 4.1.0 on all the machines, which I guess helps explain the odd behaviour.

I’ll give v.4.1.1 a try and will post back if similar issues occur. Equally, if you’d still like me to recompile and do some tests locally - I’d be happy to try and help (but would need the instructions you mentioned - as the one time I tried to recompile dynare++ I never got much beyond the Lapack / Atlas stage…).