Simult with auxiliary variables

I am trying to do a simulation with a model that has more than 1 lead (+2,+3). Dynare creates some auxiliar variables like ‘AUX_ENDO_LEAD_178’ in M_.endo_names.
When I tried to do a simulation of order 1, it is clear that the matrices in oo_.dr are using the auxiliar variables. But how can I relate each auxiliar variable to a original variable to create the initial point y0?


Thank you.

Have a look at AuxiliaryVariables - DynareWiki

Thanks, professor Pfeifer.

I understood how each auxiliar variable is related to the original variable. But I still have some questions about a simulation.
When I use a simult_ command, I need a initial point y0 in:


I would like to make a counterfactual, changing the shocks (ex_) for example. Then I usually get the initial point of economy from oo_.SmoothedVariables.Mean. But when the model has more leads than +1, I should input in y0 expectations like k(+1) , k(+2) and so on. However in SmoothedVariables I just have actual values for k in t+1, t+2, that are not known in t.

I don’t know if I made some mistake. Would you help me, please?

Unfortunately, this is a problem in Dynare 4.6 that has not yet been fixed. See

Thank you again, professor Pfeifer.

Hi, professor Pfeifer.

I understand that the issue has not been fixed yet, but I would like to have some preliminar results for my simulations. I was thinking of take all the estimated parameters (mean) and use them in another mod file, but now with calib_smoother and then run the simulations.
Does it seem to have a similar result that it would be if I run it after the issue is solved (apart from Jensen’s inequality)?

Thank you very much again.

In the unstable version, you now have a workaround available with the consider_all_endogenous_and_auxiliary-option which allows including auxiliary variables.

Thank you very much, professor. I will install it and come back here later.

I am using the 4.8-unstable-2021-08-19-1308-d3678edb version now.
I could estimate the model but when I tried to update the decision rules with “resol” command if received the message:
‘mjdgges’ is not found in the current folder or on the MATLAB path
Then I found a file mjdgges.mex in the folder …\mex\matlab\win64-9.4-9.10
Is this the one I supposed to use? I included this folder in the path of matlab and it seems to work.
Would you help, please?

This looks like a path inconsistency between different versions. Did you correctly install the unstable version?

Apparently it is correct. I removed all the references of my previous version (4.6.3) from the path and added the matlab directory inside the folder of the unstable version (dynare4.8-unstable-2021-08-19-1308-d3678edb\matlab).
One other thing that I have noticed is that the model_results.mat is saved inside the folder \model\Output. In my previous versions this object was saved always in the root directory where the .mod file was (i.e. outside the folder \model).

Yes, see

Thank you to explain it.
About the path inconsistency of the unstable version is there some other thing that I have to check?
Is the path that I added correct, right?
Thank you

No, usually everything is correct.