Running octave 3.6.2. and dynare


I’m a new user, and I’ve already problems launching the program. Right now I’ve got Octave 3.6.2. and Dynare 4.3.1, but I have problems. When I want to run the example file (just the way it is described in “Quick start” … uick-start) Dynare breaks down. I’ve been googling for the problem, and I’ve tried to invert simple matrices in octave, but it breaks down again. The message I always get
"panic illegal instruction stopping myself attempting to save…"

To overcome the problem I’ve tried many things:
1.install older versions of octave and dynare which are compatible (e.g. Octave 3.2.4 with Dynare 4.2.4). In that case I could invert matrices, but when I wanted to run the example file like in the “Quick start”, Dynare it broke down again.
2.install cygwin and run octave there, octave could invert matrices, but I couldn’t launch the example file like in the “Quick start”.
3. in both cases I tried to run other example files, they didn’t run neither.

However, when I run “edit example1.mod” from the “Quick start”, Dynare opened the code. It didn’t break down.

I have no idea what to do, thank you for your help in advance!



Are you using Octave 3.6.2 MinGW downloadable from Dynare website?

Are you able to do simple calculations in Octave 3.6.2?

Also, what is your version of Microsoft Windows?

Can you post a full log of the crashing session?

Yes, I use that Octave (the one that is put on the following link: )

When I’m trying to run the example file:

panic:illegal instruction --stopping myself…
attempting to save variables to ‘octave-core’…
save to ‘octave-core’ complete

When I’m trying to invert a matrix, I get the same message. But matrix multiplication works. Other calculations I haven’t tried.

I have a Windows 7.

Thanks for your feedback.

Hence it is a problem with your Octave installation. It has nothing to do with Dynare.

I suggest that you wipe out all existing Octave installations and perform a fresh install.

If that does not help, I have another idea to try:
] open the windows explorer/:m]
] go to c:\Octave\3.6.2_gcc4.6.2_2012XXXX\bin/:m]
] overwrite libblas.dll by libblas.dll.atlas-3.8.4_corei5/:m]
] if that still does not work, overwrite libblas.dll by libblas.dll.ref/:m][/ul]

If that still does not work, I am clueless. You can try to contact the Octave people as explained there: