Running Dynare++ on Mac


I have installed Dynare 4.1.3 on Mac OS X 10.5.8, following the instruction online. Dynare runs perfectly fine. But whenever I type
dynare++ filename.mod
in Matlab, I get the error message
??? Error using ==> dynare Too many output arguments.
I also tries to run Dynare++ in the command prompt and have copied the executive file dynare++ into the directory where I put my mod file. But I still get the error message:
-bash: dynare++: command not found

Maybe I was doing it in the wrong way. I have read the online manual but it doesn’t give a detailed instruction, especially for the Mac version. Any help will be greatly appreciated!


Dear Erica,

For the cleanest solution, instead of copying the dynare++ executable into the directory in which you’re working, please try the following:

  1. Open Terminal (Applications->Utilities->
  2. At the command prompt type: cd <<the directory in which your .mod file is located>> and hit enter
  3. At the command prompt type (on the standard Mac installation): /Applications/Dynare/4.1.3/dynare++/dynare++ <<filename.mod>>and hit enter. If your installation is nonstandard, replace /Applications/Dynare/4.1.3/ with the path to your root dynare directory.

NB: you can also copy the dynare++ executable into your working directory. In this case, you would need to issue the following command: ./dynare++ <<filename.mod>>

Either method should produce the files described in section 7 of the dynare++ tutorial. If it does not, please respond with your .mod file.

You are right, we should update the manual with instructions for Mac.


Dear Houtan,

It works now! Thanks so much for your help!



I have a .mod which works with the normal dynare command.

I’m trying to compile the same file with dynare++ I have follow your instructions but then I have the following error message in the terminal:

Caught Dynare exception: Parse error at BGCalvo, line 1, column 101: syntax error, unexpected $end, expecting PARAMETERS or VAR or VAREXO

Could you help me please?

Best Regards,


I guess you’re missing a semicolon.

If you want more help than that, you need to:

  1. Tell me the version of Mac OS X you’re using
  2. Tell me the version of Dynare you’re using (if it’s not 4.3.2, I will first ask you to upgrade)
  3. Post the .mod file that is producing the problem.

I use dynare++ on daily basis. I wrote many models during the last 10 months. Everything is ok.

I bought a mac two months ago. Nevertheless, I am still using my old laptop with windows.
When I try to run dynare++ I get the following error:

/bin/bash: dynare++: command not found

I tried the suggested procedure, but I still have the problem. Can someone give me some help?

This means that the folder containing the dynare++ executable is not in your PATH variable. At the terminal prompt, type:

And try to execute dynare++ again.

I have done all the above suggestions, but still got a problem. It says

dyld: Library not loaded: /usr/local/lib/libmatio.2.dylib
Referenced from: /Applications/Dynare/4.4.2/dynare++/dynare++
Reason: image not found
Trace/BPT trap: 5

Could you help me on this?

Thanks a lot!

This means that dynare++ was compiled with a shared matio library and not the static one.

If you need to use it soon, I would recommend you download Homebrew ( and install the matio package.

Otherwise, you can try the dynare++ executable from 4.4.1 or 4.4.0 as nothing has changed between these versions. Just copy and paste /Applications/Dynare/4.4.0/dynare++/dynare++ into /Applications/Dynare/4.4.2/dynare++/.

I’ll make a new package sometime next week to fix this, so if you want to wait and download it directly you can wait until then. I’ll post a response here once I have made it.

Here’s the dynare++ binary from the 4.4.0 build.
You can download it and copy it into the /Applications/Dynare/4.4.3/dynare++/ folder. If it doesn’t work, please let me know.

I am also trying to run Dynare++ on Mac but it’s not running. The mod file runs successfully in Dynare but Matlab is not calling Dynare++. It shows “too many arguments error”. I tried all instructions provided on this forum but failed every time.
It would be helpful for me and for many others if someone writes down the steps to follow.

@wmutschl Have you tried this?