Residuals are not equal to zero yet solves the model


How is it possible for dynare to solve the mod file when the residuals of static equations are not equal to zero?


It uses an equation solver. The residuals are only the residuals at the starting values for the steady state search.

Hello thanks for your reply. After solving the model, I check the residuals with resid(1) and the residuals of the static equations were non-zero. I find it puzzling that dynare solves the model without any error.

How big are the residuals? Dynare has a tolerance of about 1e-6.

Residuals are from 0.32 to 14.2.

That is strange. I would need to see the files.


I have attached the file. updatediv.mod (19.1 KB)

The problematic variables are “log_div” and “log_dep_saver”. I tried values for both of these variables and the code runs however the residuals are not zero.

I also tried putting equations in the initval, but, residuals are 0.018494 and 0.0001767 with error impossible to find the steady state.


As I said, you need to check residuals after steady state computations, not before. Putting resid after steady shows residuals smaller than 1e-6.

1 Like

Thanks for your reply.