Rank Condition and BK condition

Hi,

Could you please check what is the problem with my model? The timing of the model looks fine to me still I am getting the following error:

There are 4 eigenvalue(s) larger than 1 in modulus
for 5 forward-looking variable(s)

The rank condition ISN’T verified!

Error using print_info (line 32)
Blanchard & Kahn conditions are not satisfied: indeterminacy.

Kindly help. w_sm.mod (6.1 KB)

Best Regards
Sahil

I the value of some parameters and the simulation is working now and the rank condition is verified (w_sm.mod (6.1 KB) ). However, when I am doing Bayesian estimation, I am getting the error:
You did not declare endogenous variables after the estimation/calib_smoother command.
Error in computing likelihood for initial parameter values

ESTIMATION_CHECKS: There was an error in computing the likelihood for initial parameter values.
ESTIMATION_CHECKS: If this is not a problem with the setting of options (check the error message below),
ESTIMATION_CHECKS: you should try using the calibrated version of the model as starting values. To do
ESTIMATION_CHECKS: this, add an empty estimated_params_init-block with use_calibration option immediately before the estimation
ESTIMATION_CHECKS: command (and after the estimated_params-block so that it does not get overwritten):

Error using print_info (line 32)
Blanchard & Kahn conditions are not satisfied: indeterminacy.
us_data.mat (11.6 KB) Woodford_BNK.mod (9.4 KB)

Please help.

Best
Sahil

Use

estimated_params_init(use_calibration);
end;

Dear Johannes

Thank you for your reply. However, my file is still not working and I am getting the following error:

Cannot use parameter values from calibration as they violate the prior bounds.Error using check_prior_bounds (line 39)
Initial value(s) of phi_y, gama, phii, eta_m are outside parameter bounds. Potentially, you should set
prior_trunc=0. If you used the mode_file-option, check whether your mode-file is consistent with the priors.
Error in check_prior_bounds (line 39)
error([‘Initial value(s) of ‘, disp_string ,’ are outside parameter bounds. Potentially, you should set
prior_trunc=0. If you used the mode_file-option, check whether your mode-file is consistent with the priors.’])
Error in dynare_estimation_init (line 354)
check_prior_bounds(xparam1,bounds,M_,estim_params_,options_,bayestopt_)
Error in dynare_identification (line 300)
[dataset_, dataset_info, xparam1, hh, M_, options_, oo_, estim_params_, bayestopt_, bounds] =
dynare_estimation_init(M_.endo_names, fname, 1, M_, options_, oo_, estim_params_, bayestopt_);
Error in Woodford_BNK.driver (line 428)
dynare_identification(options_ident);
Error in dynare (line 293)
evalin(‘base’,[fname ‘.driver’]) ;

Please suggest.

Best
Sahil