Ramsey policy error message

Hi everyone,

Apologies for the (very) stupid question but I am currently stuck with an error message related to the Ramsey policy command. I have tried to search the dynare forum regarding this error message but unfortunately I couldn’t find anything. Furthermore it is my first time that I look at the optimal policy.

My model features taxes and I use an external steady state file. I had look at the github examples but I wasn’t able to figure it out. The error I get is:

You have specified more instruments than there are omitted equations

I am more than happy to share my codes or look at another examples which I might have missed during my search for the error message. I should mention the model runs perfectly without the Ramsey command.

Many thanks for your help.


Say your model features 10 variables, so you need 10 equations. If you now use 2 instruments, you are left with 8 equations determining the remaining variables that are not used as instruments. But in your case, there are still 9 or 10 equations in the model-block.

1 Like

Many thanks Johannes, I understand what you are saying and now it makes sense. Based on your reply I got the model to run, however ended up with:

Ramsey: The solution to the static first order conditions for optimal policy could not be found. Either the model doesn’t have a steady state, there are an infinity of steady states, or the guess values are too far from the solution

I give it more thought and post again in case I’m still stuck with the same problem. Thanks again for your help.

Did you use a conditional steady state file?

Hi Johannes,

I have used an external steady file for the computation. I’d be more than grateful if you could quickly run the model. Hopefully I haven’t made the same mistake as in this legacy post. If turns out that this is the case, I will fix the problem according to your advice in the post.

I get the same issue. Have you tried what happens if you use only one instrument first?

Thanks, I will try that and report back.

Hi Johannes,

I reduced now the instruments down to one and now I receive the following error:

Ramsey: The maximum number of iterations has been reached. Try increasing maxit.

Do you know how I can increase the number of iterations? I tried everything from checking dynare_solve and the optim=() option with “maxit” but dynare didn’t recognise the option. Do you know how I can change the iteration number?



Set options_.ramsey.maxit

Just a quick update I ran the Ramsey policy command for both instruments individually and set

options_.ramsey.maxit = 5000;

Unfortunately, I still end up with:

Ramsey: The maximum number of iterations has been reached. Try increasing maxit.

I guess that increasing maxit won’t solve the problem. Do you think this might have something to do with the conditional steady state? Many thanks for helping me with this!

No, the conditional steady state is fine. You would get an error if the private sector equilibrium conditions were not satisfied. Rather, the problem is that no steady state for the Ramsey problem itself is found. Have you tried the other instrument? Maybe for the one you are considering right now no steady state exists?

I see. I’ve tried both instruments but with the same outcome. There’s a third one which I could potentially use. I will give it a try. But as you said, in the end it might not be even feasible. Thanks for your help Johannes.