Ramsey policy and instruments

Hi, I have a question about the ramsey policy. Do I have to specify the variables of the instruments? I note that in the example that dynare provides, it seems okay not to specify the instrument option. However, when I run a model by myself, it gives the message:

[quote]Reference to non-existent field ‘instruments’.

Error in dyn_ramsey_static (line 43)
instruments = options_.instruments;

Error in evaluate_steady_state (line 55)
[ys,params] =

Error in resol (line 108)
[dr.ys,M.params,info] =

Error in stoch_simul (line 76)
[oo_.dr,info,M_,options_,oo_] =

Error in ramsey_policy (line 25)
info = stoch_simul(var_list);

Error in model_ramsey2 (line 727)

Error in dynare (line 120)
evalin(‘base’,fname) ;

Thanks a lot.

Have you tried the unstable version? If the problem persists, please provide the codes.

the unstable version works. thanks.

I am facing a similar problem. When I ran my code in the Dynare 4.4.3 stable version the error was as follows:

Reference to non-existent field ‘G_hat’.

Error in read_variables (line 84)
dyn_tmp_01 = s.(deblank(var_names_01(dyn_i_01,:)));

Error in initialize_dataset (line 32)
rawdata = read_variables(datafile,varobs,],xls.sheet,xls.range);

Error in dynare_estimation_init (line 475)
dataset_ =

Error in dynare_estimation_1 (line 81)
[dataset_,xparam1, hh, M_, options_, oo_, estim_params_,bayestopt_] =
dynare_estimation_init(var_list_, dname, ], M_, options_, oo_, estim_params_,

Error in dynare_estimation (line 89)

Error in code1a (line 430)

Error in dynare (line 180)
evalin(‘base’,fname) ;

**Then I followed the advise given in this forum and tried running the code from a new folder using the unstable version as of 28 Dec 2015. However still I get the following error: **

Error using evalin
Undefined function or variable ‘emptydatesobject’.

Error in dates (line 73)
dd = evalin(‘base’,‘emptydatesobject’);

Error in global_initialization (line 347)
options_.initial_period = dates(1,1);

Error in code1a (line 15)

Error in dynare (line 180)
evalin(‘base’,fname) ;

Please help me understand the errors and how can I resolve them?

Best Regards,

The first error is related to your observed variable not being contained in the dataset. The second seems to be a problem with your Dynare path settings. Clear all paths to Dynare from the Matlab path and then reset them.