Question about estimation

Now I waited for 12 hours and nothing happens after Figure 1 appears. I don’t think my computer is the reason for this, because it has 16 GB of RAM.

At which stage does the freeze happen, i.e. after which output?

One missunderstanding: Octave freezes now, after I updated Octave and Dynare to new versions. Before, there was no notification that “This program doesn’t respond” and file in gray, so I couldn’t click anywhere. I tried to replicate at least previous simple file without command estimation, with only stoch simulation, which was possible before, but now even with this, everything is gray after Figure 1 pops up.

Before, when I said “everything freezes”, I meant that nothing additional happens when Figure 1 pops up, and not that program stops responding.

But what is Figure 1? What’s the last output in the command window? And which configuration exactly are you using?

Figure 1 is “Orthogonalized shock to epsilona figure 1” (the pop-up window). The last output in command window is “Approximated coefficients of autocorrelation”. Regarding configuration, I’m not sure. Evertyhing is default, I didn’t set anything manually.

I meant Dynare version, Octave version, operating system.

Oh, it’s Dynare 5.4, Octave 8.2.0 and Windows 10.

But Dynare 5.4 only supports Octave 8.1 as written above.

This is a bit confusing. Immediately after installing Octave 8.1, I was able to obtain an error message after running the file with estimation command. However, after closing Octave and running it later again, both windows freeze again. Even after restarting computer and trying multiple times, both simple file with stoch simul command, as well as file with estimation command, both cause Octave to freeze.

I don’t have any experience with estimation of DSGE models. I’m trying to replicate the structural parameter stability tests, as conducted by Mr Oke Röhe (a comparison of parameter instability between countries).

@redbanana I can confirm the issue in Octave 8.1. The program freezes during the call to
in dyn_saveas after the first IRF figure was generated.
@sebastien Can you reproduce the problem on Linux?

@miikebross What exactly is your question?

It works fine under Linux (it crashes later about missing estimated_params block).

So it looks like a Windows-specific issue. You could try with Octave 8.2.0 (Dynare 5.4 will print scary warnings but the MEX should be compatible), even though nothing in the changelog from 8.1.0 to 8.2.0 mentions EPS plots, so chances that the problem is fixed are low.

I think I can trace the problem back to GNU Octave - Bugs: bug #47337, [Windows] fltk toolkt: infinite... [Savannah]
The problem seems to be the Intel OpenGL driver. When using Octave’s OpenGL Switcher Tool to select “software OpenGL”, the problem does not appear anymore.

Could you please tell me how to use Octave’s OpenGL Switcher Tool to select “software OpenGL”? I can’t find this tool in “Tools” section of Octave.

It’s an App on Windows called OpenGL Switcher. You should be able to access it from the Start Menu of Windows.

Note that software OpenGL is markedly slower than regular OpenGL (because it uses software emulation rather than specialized hardware in your graphics card). So you if you are using other applications with heavy graphics need, you may want to revert that setting before launching those, because otherwise you may experience a performance loss.

I tried setting OpenGL Switcher to software, but after running my Dynare model file, again everything freezes after first chart pops up. I’m not using any other program apart from Octave.

Did you click on “Apply” or “OK”? I initially had trouble really switching.

I tried both clicking on Apply as well as Close, and even both Apply and then Close, but in all cases, after first window popped up, nothing happens. Does it matter if I do it before I open Octave, or afterwards?