Problems with dynare++ parser


I’ve converted a ‘matlab’ version of two different “.mod” files to dynare++ form, but when I try to run them, I can’t seem to get past the parsing stage. The error dynare++ returns when I try to compile the files (identical in both cases) is:

Caught ogu:: Exception: fine_atoms.cpp:278: FineAtoms::outer2y_endo called before parsing finished

Any suggestions what I should be looking for? I was wondering if this might have anything to do with the size of the models (both >200 variables) as I don’t have any problems running simpler model files…

As an aside, is there a way to use the pound sign (#) in dynare++ (I’ve re-declared my model to avoid problems, but just for future reference)?

Thanks in advance,

Unless Ondra added the feature recently, the # expression aren’t permitted in Dynare++

You problem comes either from a syntax problem in your *.mod file or from a problem arising from the large size of the *.mod file.
In order to understand what is going on, I would need the *.mod file and also to know more about the dynare++ version that you are using.
Are you working in Linux or Windows?
Did you dowload a binary version or did you recompile on your machine?



Hi Michel,

Thanks for your reply. In response to your questions:

  • I am using dynare++ Version 1.3.2
  • I am using the Windows version
  • I did not recompile anything - just downloaded the binaries of the web on Monday.

Unfortunately, due to security restrictions in place on my workstation, I am unable to upload the relevant files here (which is why I didn’t include them previously) - but I will send them in a separate email to your address - hope that is ok.

I’ve been playing with the files a bit, so a few comments that might, perhaps, be of some use:

  • I suspect the size of the model is not the issue here. I stripped the model down to 36 variables (eliminating over 200) and got rid of all comments etc. (the file size fell from 40K to around 4K) but get exactly the same error message. At present the model seems smaller than some of the example files included with dynare++ which run without problems.

  • I have taken the same model file and exchanged the vcov = ]; and order =; bits with steady; shocks; and stochsimul and the whole thing runs smoothly under Matlab. This would suggest that I messed something up in the dynare++ specific section - but I just can’t spot an error. In any case, I will send you both versions of the file one called ‘STRPLUS.MOD’ and the other called ‘STRPLUSMATLAB.MOD’.

Thanks again for your help,

Dear Pawel,

I am sorry I didn’t get to your issue earlier.

The error you get is probably my bug (bug in dynare++). This kind of exception should not be obtained by the users. Dynare++ has not intrinsic limits on the size of the model files nor a number of variables.

Can you post the mod-file to the forum? I will look at it.

Most likely the error is caused by using multiple leads (leads greater than 1). The internal orderings are not created and then dynare++ whines that it cannot find the orderings.

If this is the case, I have already committed version 1.3.4, which allows for multiple leads. It is not realeased yet, so you cannot find it in the download area. I still need correct for a bug which appears only if one uses multiple leads together with optimal policy. I doubt I would be able to release it before May 07.


Ondra K.

Dear Ondra,

Thanks for your reply - and no worries about the delay.

I think you’re exactly right and the problems I described here are related to leads greater than 1 (and using a substitution rule allowed me to deal with them).

However, in the meantime, I’ve been experiencing other sorts of unexpected dynare++ behaviour, which, I thought, you might be able to help with.

The most serious of these problems is that I have several models that run smoothly when expanded to second order, but crash when I try to do a third order expansion. I was wondering if you’ve experienced that sort of behaviour before (the error message I’m sometimes getting is: Caugth TL exception: At ./t_container.hweb:223:NaN or Inf asserted in TensorContainer::insert).

I’d be happy to send you the files that cause trouble if you’d like and if that’s ok (unfortunately, due to security restrictions in place on all PC’s at work I’m unable to upload any files to the forum).

Thanks in advance for your help,

Dear Pawel,

I am ending this thread by concluding that the bug you pointed out will be solved when dynare++ 1.3.4 is released.

in regards to your new problem, I will start a new forum thread.

Ondra K.