Problem with running Dynare files

I have Dynare 4.6.3 in Matlab R2020b and it always worked; since today, I am not able to run a .mod file that I have already run in the previous days.
The error message is: error in using var, too many inputs. I used var in dynare to introduce endogenous variables but the error message talks about var as the variance in matlab…It seems that it did not recognize that I am working on dynare. Thus I decided to delete the matlab file whose title was “var.m” to see if after deleting that file, I was able to run my mod file. At this point, I have this message error “Previously accessible file “C:\Program Files\MATLAB\R2020b\toolbox\matlab\datafun\var.m” is now
inaccessible”. This is because I deleted that file. But again, it seems that I have not dynare when actually I have it installed and until yesterday, things worked…
I have tried to change directory but it did not solve the problem… any suggestion?
Thanks very much in advance.


I would need to see the full error message and mod-file.

tank_cw.mod (4.2 KB)

Why does the code of the mod-file appear in your command window? It seems you did not execute your mod-file properly but instead tried to run your mod-file as Matlab code.

Yes, thank you! I did a silly mistake