Problem with Ramsey Planner and with Stochastic Extended Path


Hope you are well. I’m facing two issues. (using Dynare 5.4).
The code runs ok for stochastic simulations.

  1. When I try to call Ramsey problem with commitment:

planner_objective welf;

It says “Error using eval
Unrecognized function or variable ‘optimal_policy_discount_factor’.” I tried with the numerical value of the DF and different ways to call beta but I always get the same issue.

  1. The problem runs ok for perfect foresight. But I’m trying to do an exercise with stochastic extended path (if you uncomment the last lines of the code) and I always get the same issue:

"Unrecognized field name “Omega”.

Error in setup_integration_nodes (line 9)
nodes0 = repmat(nodes0,1,pfm.number_of_shocks*pfm.stochastic_order)*kron(eye(pfm.stochastic_order),pfm.Omega);"

Thank you so much,

model.mod (10.1 KB)
model20_steadystate.m (310 Bytes)
param.mat (3.9 KB)
run.m (1.2 KB)

I get various issues with your model.

  1. You specified a negative variance.
  2. The naming of the model and the steady state file do not match.
  3. Not all parameters you are trying to pass back in the steady state file have been set. You should provide a proper steady state file.

Thank you. Yes, the variance was a typo I had. I simplified the code. Basically it’s the Sims and Wu 2021, but I’m trying to compute a Ramsey Problem. I attached the simplified codes. They run ok for stochastic simulations but I still get always the same problem for both Ramsey command and the stochastic extended path. Maybe you are right with some parameters missing but I could not find the bug nor understand why PF or stoch sim runs ok.

Regarding the name of the SS file: this is strange, I see it in my folders as model_steadystate but when I upload here it says model20, I saved again under the correct name but still uploads with the “20” so I don’t think thats the issue of Ramsey and the SEP problem.


Thank you
model.mod (8.4 KB)
model20_steadystate.m (310 Bytes)
param.mat (2.8 KB)
run.m (177 Bytes)



files are still missing.

Hi, here are all the files. Basically, the main problem is that I can’t run the Ramsey problem. Maybe is bacause I call the Discount factor “beta” and that causes a conflict with the internal matlab language?

model.mod (8.4 KB)
model20_steadystate.m (310 Bytes)
param.mat (2.8 KB)
run.m (177 Bytes)
model_ss.m (3.0 KB)
param_save.m (1.8 KB)
param_ss.m (2.2 KB)

You need to use a proper steady state file that sets all variables. A starting point is:
model_steadystate.m (2.7 KB)