Problem with estimation with mh_replic

I am doing Bayesian estimation with 1.5 million draws (with 2 mh-blocks).
I’m extending my draws using ‘mh_replic’ for many times because of the estimation time issue.

The estimation proceeded smoothly up to about a million draws, and the acceptance rate was also appropriate at around 25-30%.
However, as I exceeded a million draws, the acceptance rate of chain 1 suddenly dropped sharply, leading to diverging univariate diagnostics graphs.

What could be the issue here, and how can it be addressed? Additionally, is there a way to revert back to the estimation results before the decline in acceptance rate and re-estimate?

I attached my mod file and a univariate diagnostics graph.

Thank you in advance for your help.
paper_bayesian_16sec_hpfiltered88_2_udiag3.eps (75.2 KB)
Estimation_16sec_hpfiltered88_2.mod (4.9 KB)

You should inspect the trace_plot to see what is going on.

I checked my trace plot for chain 1.
It looks fine for 1 million draws, but starts to diverge for almost every parameters after that.
I attached some trace plot figures below.

Could you help me to solve this problem?

TracePlot_rhomu7_blck_1.eps (218.2 KB)
TracePlot_SE_vmu1_blck_1.eps (219.0 KB)
TracePlot_rhoa1_blck_1.eps (217.0 KB)
TracePlot_rhoa2_blck_1.eps (219.6 KB)
TracePlot_rhomu1_blck_1.eps (217.3 KB)
TracePlot_rhomu2_blck_1.eps (219.5 KB)
TracePlot_SE_va1_blck_1.eps (219.4 KB)

It seems there is a second mode that the model converges to. How does the trace plot for the posterior look like? Is it a region of higher or lower density?

Thank you again for the reply, professor.
Trace plot for the posterior seems diverge to higher region.
Here’s the graph of it.

TracePlot_Posterior_blck_1.eps (220.4 KB)

Then you should restart mode-finding at the last parameter draw in the chain.

Then I have a following questions.

  1. Is your suggested solution means that I should find the mode again by setting the initial values as the last draw in the chain 1? Is it effective although my chain 2 is fine?
  2. Could you briefly explain what was the problem and how restarting mode-finding is the solution?
  3. What I did is find the mode with ‘mode_compute=4’ first, and then from those mode I found, I find mode again with ‘mode_compute=7’. I tried two algorithm so that I can find the mode correctly and reduce the mistakes like this case. Is it ineffective way?

I really appreciate your help. Thank you!

If you look at the trace plot of the posterior, you can see that the chain at the end drifts to region of higher posterior density. That means the initial mode was not the global mode. The MCMC thus explored the wrong region. If chain 2 did not drift away, it simply means it stayed stuck at the local mode.
Sequential mode finding is the suggested way. In Dynare 6, the additional_optimizer_steps option does that for you.