Parallel Configuration

Dear all,

I have tried to run an estimation using parralel computing solely on my computer and I keep getting the following error:

PsExec v2.34 - Execute processes remotely
Copyright (C) 2001-2021 Mark Russinovich
Sysinternals -

Nßzev adresß°e je neplatnř.

PsExec could not start C:\MATLAB\R2020a\bin\matlab

If it helps, “Nßzev adresß°e je neplatnř.” means “The directory name is invalid.”. But I am sure that the directory of MATLAB is alright:

Screenshot 2021-08-24 212209

When I run parallel_test, everything seems to be okay but then the MCMC gets stuck on the “Initialize”. I have tried everything but to no avail. I followed the steps described in the manual.

  • SMB is in place
  • PsTools succesfully installed
  • (hopefully) correct configuration file - I have tried to call the file directly via conffile and also automatically by placing it in the AppData folder, still the same error
  • the Windows System Path is set to C:\dynare\PSTools
  • executed psexec.exe without an error message
  • restarted my computer

dynare.txt (211 Bytes)

Do you have any idea where the problem might be?

Thanks for any help.


On Windows, you usually don’t need the Matlab path. What happens if you leave it out?

Exactly the same error appears:

PsExec could not start matlab:

Is that the verbatim message? Also, does the example config file from the manual work?

@jpfeifer Yes, it is the exact message. Just so you have all the information, I’m attaching a log from running the parallel_test and also a log from the parallel command. I’ve tried to use the example config file but to no avail, the result is the same.

parallel_test.txt (570 Bytes)
parallel.txt (3.6 KB)
config.txt (150 Bytes)

What happens if you type in the Matlab command window



Another Matlab opens.

I am at a loss here. The last thing you could try is to put the mod-file into a shorter folder name with no spaces in it. Maybe

C:\Users\marti\Desktop\Diplomovß prßce\ESTIMATES and MODELS\NEW ESTIMATES\FINAL ESTIMATES\test para

is the problem.

I think I have tried that before but I’ll try one more time. However, could it be a problem that I have two Matlabs on my computer? 2020 and 2018

  1. It’s unlikely, but may be the case. The weird part is that obviously Matlab can be run from the command line as you verified with
  1. Another potential culprit may be an antivirus program blocking execution. See e.g. PsExec: The SysAdmin's Swiss Army Knife
  2. A third option is unsufficient permissions, e.g. windows xp - PSExec cannot find explorer.exe? - Super User

@jpfeifer Coming back with good news! It works now! The issue was in the .mod file path indeed. I’ve tried to put the .mod file directly into C: and everything works now.

Thank you very much. I really appreciate it. As always you saved the day!