One shock doesn't show up in Policy and Transition functions

Hi All,

I am using dynare version 5.2.

I am trying to replicate a simplified version of Alichi et al 2009(IMF WP) where the NK model has imperfect credibility.

In the basic NK model, I have introduced credibility which affects the NKPC, IS curve etc. The exog shocks in the model are TFP, preference, monetary policy and credibility shock.

The model simulates and gives me IRFs for the first three shocks but not for credibility. The credibility shock also doesn’t show up in the policy and transitions functions. I have tried different order for simulation, but it still doesn’t work. I am unable to figure out where the issue is.

Any kind of help would be appreciated. the mod file is attached.
NK_calvo_NL_cred.log (212 Bytes)

Thank you,

I added ‘irf_plot_threshold=0’ and all the IRFs are zero. But I don’t understand why it has zero effect on all the variables.

You only uploaded the log file, not the mod-file.

Apologies @jpfeifer , here is the .mod file.
NK_calvo_NL_cred.mod (3.5 KB)


cred*Pi(+1) + (1-cred)*Pi(-1)

Linearizing this with respect to cred about the steady state of Pi=1 should give a zero. Hence, there should be no effect at order=1.

Thank you, Prof. Pfeifer, I see what the issue is. The same problem is still pertaining at order=2. Do you recommend changing the steady state values? Will it be better if I use values from Fsolve?

Thank you.

This looks more like a fundamental modeling issue. Are you sure the setup and the solution technique are consistent?

I have tried to incorporate the credibility in the most simplest way possible. Alichi et al have endogenous credibility which I wanted to simply.

To my knowledge the setup is correct. I guess a better way is to solve the model without using dynare but I am unsure. I wanted to try out the model with dynare before solving it the other way.

Do you think that would be a better way to solve it?

Thank you.

I skimmed over

The main difference seems to be that they start from a linear model, while you are trying to implement the setup in a nonlinear model where it drops out during linearization.

Thank you. I’ll try to solve it without dynare or change the model somehow to avoid the issue that arises after linearization. Thank you once again.