Octave 4.4.1 doesn´t run models

Hello I have an issue using Dynare 4.5.6 on Octave 4.4.1 it displays thet dynare does not support that version and suggests to install 4.4.0 but neither that one runs. I would like to know if it is a problem on my computer or if it is a general issue, and either case how to fix it.

If you are under Windows, then Dynare 4.5.6 needs Octave 4.4.0, more precisely this exact binary: https://ftp.gnu.org/gnu/octave/windows/octave-4.4.0-w64_1-installer.exe

Can you try reinstalling Octave using the above link? If this does not work, could you please post the error message?


Hi I find the following message and Dynare not working. I have tried four octave versions

windows 10
Dynare 4.5.7
Octave 4.0.0, 4.2.1, 4.2.2,

error: dyn_first_order_solver: could not find library or dependencies: C:\dynare\4.5.

Can you confirm nochange is associated to new versions?
Any suggestion will be appreciated
Thanks in advance


For Dynare 4.5.7 under Windows, you must install Octave 4.4.1. It will not work with any other Octave version.

Here is the download link: https://ftp.gnu.org/gnu/octave/windows/octave-4.4.1-w64-installer.exe


Thanks for the info, @sebastien — I had the same problem as @pdiazs .

I don’t suppose there’ll be a version of Dynare compatible with Octave 5.1.0 anytime soon?

It’d also be great if you could update the download page to more explicitely state that only Octave 4.4.1 is supported by Dynare 4.5.7, no later (or earlier) versions.

Thanks, and thanks to all the team for your work on Dynare! :+1:

I have modified the download page on the Dynare website to say more clearly that only version 4.4.1 is supported, and I have added the download links for Octave.

Also note that the unstable/snapshot version of Dynare is compiled against Octave 5.1.0. So you can use that one, if you’re willing to leave the safe world of stable releases.


Per the instructions on the Download page, I installed Octave 4.4.1 and then Dynare 4.5.7.
After installation, I type “dynare” in Octave’s command window and get the following msg:

“error: ‘fname’ undefined near line 36 column 12
error: called from
dynare at line 36 column 1”

Greatly appreciate your help.


Hi Amir,

This simply means that you did not provide a .mod file on the dynare command line.

Thanks, Sebastian. Yes, that was a good sign that Dynare is installed fine:slight_smile:

When I run the “example1.mod” in Octave, it finishes the process and then closes the Octave window. I suspected this has to do with Octave than Dynare. Reading on this, I was dragged into another area that relates this error to uninstalled packages in Octave…trying to update the Octave packages, I got another error msg saying that the Forge cannot read URL, etc. etc.

I used to use Dynare in Matlab, and it was great. With Octave, it is a pain.

Any suggestion is highly appreciated!

Hi Amir,

Unfortunately, without further technical details, there’s not much I can do to help you.