Not enough input arguments


I want to alter an excisting mod file for further evaluation of the model. The problem is that the excisting mod file is not running on my Computer. The originator mentioned that on his computer everything would run well. I use matlab 2014a and dynare 4.4.3.
The error message is

Error using check_model (line 20)
Not enough input arguments.

Error in stoch_simul (line 65)

Error in fbc1 (line 678)
info = stoch_simul(var_list_);

Error in dynare (line 180)
evalin(‘base’,fname) ;

but I checked multiple times the amount of endogenous variables and equations. There are as many variables as equations.
fbc1_steadystate.m (4.54 KB)
fbc1.mod (10.6 KB)

This sounds like a version conflict. The file runs on my machine. Try reinstalling Dynare and resetting the path. Also try

in Matlab to see which file was called.

Hello Mr. Pfeiffer,

I tried your proposal but it’s still not working. I tried also the version where I’ve to set the path every time new, but no reaction.
I tried it with other mod files and dynare is doing well.

The command which check model I end on the path to dynare as explained in the instructions.

You must be doing something wrong. Searching for the file check_model.m cannot return check.m.

Thanks for help, now it’s working. I tried it at my old laptop (windows vista, matlab 2013b, dynare 4.4.3). Strange that I did exactly the same as with the new staff. Could be the reason 8.1?