No Steady state in perfect foresight model


I am working on a general equilibrium model with heterogeneous agents (TANK) and 2 sectors producing energy and non-energy good. The energy good is used both as an input for the production of the non-energy good and as a consumption item by households. The idea is to produce a perfect foresight simulation. However, I have an issue with finding the (initial) steady state (solved analytically).
I attach here the main_tank file (calling the dynare tank.mod) and the tank_steadystate file.

Thank you for your help.

main_tank.m (2.1 KB)
tank.mod (11.6 KB)
tank_steadystate.m (6.8 KB)

I can only point you to the equations with large residuals. Either the steady state computation or the entered equations are incorrect.

1 Like

Thank you for your feedback.
Unfortunately I have checked many times (I even tried to simplify the model arriving at its current version) but the model should be correct and the steady state matches. Is it possible that it is a calibration problem (there is no steady state for the parameters used) or guess value for the variables output, energy, etc. too far from the actual values?

I don’t understand your last point. You analytically computed the steady state for your model equations. That should tell you the steady state exists. Otherwise, what have you computed? Because your computations for the steady state and the equations do not match, there must be a mistake somewhere. You have one equation that shows a residual of about 10. That should provide a valuable clue.

1 Like

Okay, I will go through all the equations again and see if I can find the error (evidently there is something I am missing).
Thanks for the help.