Mode check with the positive Hessian matrix

Before lauching the Metroposlis-Hasting Algorithm, we should make sure that we already found a mode of posterior. Furthermore, the Hesseian matrix should be possitive.

In my model, I use mode_compute = 9 to find the mode of log posterior distribution. After finding the mode, dynare reports the positive Hessian matrix, then the MH algorithm is lauched.
However, I have a look at the mode_plot check, I found a strange thing as following:

Allmost figures (the attached file below) reache the mode of log posterior density, except figure4. In particular, the plot check for parameter (rpie) in figure4, it seems that rpie does not reach the mode of posterior density.However, Dynare still reports that Hessian matrix is positive, then It lauches the MH algorithm after that.
Could anyone can explain this stituation for me?
List of mode check plot figure5.pdf (7.2 KB)
figure4.pdf (10.5 KB)
figure3.pdf (7.7 KB)
Figure1.pdf (7.5 KB)
Figure2.pdf (7.7 KB)

Dear Peter,

Except for rpie the mode_check plots look fine. A lot of the curves look flat around the estimated posterior, but I think it’s a (plot) scaling issue (this can be fixed by reducing the value of mode_check_neighbourhood_size, see the options of the estimation command in the reference manual).

If you have a definite positive hessian you can go for the Metropolis-Hastings. If you are still worried about rpie you can use another optimization algorithm starting from the solution returned by mode_compute=9. To do that, you have to use the option mode_file=<NAME_OF_YOUR_MOD_FILE>_mode and change the value for mode_compute (I would try 8). But first do a copy of the file <NAME_OF_YOUR_MOD_FILE>_mode.mat because its content will be replaced by the result of the new optimization run.