Mendoza 91-Endogenous discount factor

I am trying to replicate Schmitt-Grohé and Uribe’s Endogenous discount factor model. When I run the model, I get

??? Error using ==> print_info at 57
Impossible to find the steady state. Either the model doesn’t have a unique steady state
of the guess values are too far from the solution

Error in ==> steady at 92

Error in ==> model1mendoza1 at 183

Error in ==> dynare at 120
evalin(‘base’,fname) ;

I have some troubles to introduce variable eta to the model. Is there any idea how I introduce eta? I would appreciate any help.

The issue is finding the steady state. Compute it manually and enter it into the initval-block.

Thanks for the answer. I tried it but I could not find the solution. When I run the code, MATLAB writes residuals as follows,

Residuals of the static equations:

Equation number 1 : 0
Equation number 2 : 0
Equation number 3 : 0
Equation number 4 : 0
Equation number 5 : 0
Equation number 6 : 5.6028
Equation number 7 : 2.5778
Equation number 8 : 5.6217
Equation number 9 : 0
Equation number 10 : 0
Equation number 11 : 0
Equation number 12 : 0

6., 7., and 8. equations which has eta variable. I think that is there problem with eta. Am I wrong? Or did I do something wrong while I was writing the equations in the initval block? I attached my code.
Again thank you for your answer.
model1mendoza.mod (5.87 KB)

The problem is either in the model equations or the corresponding steady state computation for 6-9. Checking equations is something you have to do.

thank you for your comments…

Hi, I am trying to simulate Uribe’s Chapter 4 of Open Economy Macroeconomics (, on page 11-2, he offered the equilibrium equations, I used them with some adaptations, but I am still having problems. Anyone could help me?
Uribe_chapter4.mod (2.69 KB)

Your timing for capital and technology was wrong. I attach a version where this is corrected. You also had a wrong (linear) option. The IRFs are still strange so there might another mistake. Note that the lecture notes of Uribe had typos in that model in an earlier version. I don’t know whether they have been fixed. So you might want to check the notes.
Uribe_chapter4.mod (2.71 KB)