Matlab shutdown Deterministic solution, stack_solve_algo=1

Dear colleagues,

I am writing because there seems to be a problem somewhere between dynare matlab when I use stack_solve_algo=1, maxit=80. Specifically, matlab shuts down whenenver I run a specific set of codes with this option. It does not shut down when I use say option stack_solve_algo=2, or 3. Here is some more information:

  • Dynare version: I tried version 4.5.6, 4.5.1 and 4.4.3
    -Matlab version: see past below
    -Error message: sometimes matlab produces an error message before shutting down, which I have attached.

Many thanks for your help!


MATLAB Version: (R2016b)
MATLAB License Number: 472001
Operating System: Microsoft Windows 10 Enterprise Version 10.0 (Build 16299)
Java Version: Java 1.7.0_60-b19 with Oracle Corporation Java HotSpot(TM) 64-Bit Server VM mixed mode
MATLAB                                                Version 9.1         (R2016b)
Optimization Toolbox                                  Version 7.5         (R2016b)
Parallel Computing Toolbox                            Version 6.9         (R2016b)
Spreadsheet Link                                      Version 3.3         (R2016b)
Statistics and Machine Learning Toolbox               Version 11.0        (R2016b)
Symbolic Math Toolbox                                 Version 7.1         (R2016b)

matlabissue.pdf (157.7 KB)

Hi Ansgar, this is a bug in the bytecode-mex-file. Could you please provide us and in particular @sebastien with the mod-file for debugging purposes.

Hi Johannes,
thanks for your quick response, here are the .mod files. You need to run dynare surprise_solution_2019_05_20. I hope it won’t be to cumbersome, I couldn’t reproduce the problem in a simpler code… (1.6 MB)


For the moment I seem to have found a workaround though, so please don’t waste your weekend on this…

@sebastien The file also crashes 4.5.7. On the unstable, after fixing nameindices.mod (1.9 KB)
I get the error

Invalid MEX-file
Missing dependent shared libraries:
'libwinpthread-1.dll' required by
'icudt61.dll' required by 'C:\Program Files\MATLAB\R2019a/bin/win64\icuuc61.dll->C:\Program
Files\MATLAB\R2019a/bin/win64\icuin61.dll->C:\Program Files\MATLAB\R2019a/bin/win64\libmwi18n.dll->C:\Program

This seems to be an issue related to compiling on Windows that needs to be fixed first.

I can reproduce the crash on both unstable and 4.5.

Since I am not familiar with the bytecode stuff, I have opened an issue and assigned it to Ferhat.

Regarding the missing dependent shared library error that you get under Windows, I can’t debug it right now (don’t have access to my Windows VM). Do you confirm that it still occurs with the latest snapshot?

Yes. I used the May 22, 2019 version (446a413). The only commit since has been your change in the Dynare++ comments.