Matlab crashes when I run Dynare

I am just starting to use Dynare and have run into a problem that I am unable to resolve on my own. I am running Dynare version 4.2.1 on Matlab 7.5.0 on Mac OS X version 10.5.8. I was able to successfully install Dynare and run the Example1.mod file contained in the installation package. My problem began the next time I attempted to run Dynare.

I wrote a simple RBC model (following an instructional tutorial I found) in order to give me some basic practice with crafting a .mod file. Upon finishing this, (which was admittedly just copying the tutorial), I decided to give it a run. Dynare will run normally up to the point where it calculates coefficients of auto-correlation for the declared variables. At this point Matlab itself crashes without returning any sort of error messages. I thought this may just be peculiar to the file I had just written, so I tried again with Example1. It ran until the point of reporting auto-correlation coefficients and then Matlab crashes.

I am lost as to what I can do at this point. In the absence of a well-defined error message, I do not know where or what the failure is. It is not something unique to the file I created as the same result occurs when I use the example files. It is especially troubling to me as I was able to successfully run Example1 immediately following installation, yet it fails only few days later.

Has anyone else ever encountered this problem or have any ideas on how to fix it? Any help or suggestions would be greatly appreciated.


Hi Adriane,

What strikes me as odd is that it worked one time with example1.mod but not the second time.

After running build_dynare.m, and adding the path to dynare/matlab, does the beginning of your output look like this:

[code][mex] Generalized QZ.
[mex] Sylvester equation solution.
[mex] Kronecker products.
[mex] Sparse kronecker products.
[mex] Bytecode evaluation.
[mex] k-order perturbation solver.
[mex] k-order solution simulation.

Starting Dynare (version 4.2.1).[/code]

or do all of the [mex] look like [m] ?

Does Dynare 4.2.0 work correctly on your machine?

And you’re certain you downloaded the 10.5 version of Dynare 4.2.1 and not the 10.6 version?

What version of XCode do you have?


Hi Houtan,

Thank you for taking the time to reply to my previous post. In response to your questions:

The beginning of my output looks identical to what you pasted. All the lines begin with [mex] rather than [m] and these lines are followed by "Starting Dynare (version 4.2.1)"
I am unable to actually cut/paste the output as Matlab closes too rapidly for me to do so.

I am in the process of downloading and installing Dynare version 4.2.0 and will post a reply shortly indicating whether or not it runs properly.

I am positive that I downloaded the correct version of Dynare (for Mac OS X 10.5) and I am currently running XCode version 3.1.4.


In regards to version 4.2.0 of Dynare, I am experiencing the exact same issue. It runs up to the point of calculating coefficients of autocorrelation for each variable and then Matlab suddenly closes. It seems as though a smaller window is appearing within Matlab just before it closes. I am unsure as to whether this window contains an error message or is simply the window that would normally appear with the figures of the IRFs.

Try installing the latest version of XCode 3 (3.2.something, I think). Look at the bottom right of this page for a link: I don’t think you can update to Xcode 4 with your system, so don’t get that.

Did that work?


The link provided allows download of Xcode 3.2.6 which is incompatible with Mac OS X 10.5 and requires Mac OS X 10.6.6. I recall that I installed Xcode 3.1.4 as it was the “latest” version that was compatible with my current setup.

I noticed that the “dynare .mod” command also creates additional files (such as an .m file of the same name) in the working directory. Could this be leading to some problems as to why I cannot replicate previous output?

Also, is it possible that the version of Matlab I am using may be causing some of these difficulties? I am running Matlab 7.5.0 (R2007b).


Could you email me the output when you run build_dynare? My email address is:

People have built and used Dynare on os x 10.5 so, as you suspect, it may be your Matlab or something else specific to your setup (old OS, Matlab and compilation environment). Let’s see what we find out from the output of build_dynare…


I confirmed the problem with the 10.5 package with Matlab 2007a. Yet to be confirmed with a later version of Matlab.

At this point, I’m not certain that I will build another 10.5 package as Apple has dropped the 10.5 SDK from XCode 4. If I build another one, I’ll post the response here.



Sorry for the delay in response. This is not a problem with the 10.5 Dynare package. Rather, it is a problem with Matlab running on OS X 10.5.8 and 10.6.8. The final updates to these two Operating Systems upgraded Java in OS X. Matlab uses Java to create figures. Essentially, this Apple update, changed the Java version that Matlab was depending on and, hence, it crashes.

To fix this for your Matlab, follow the instructions on this website: … /1-F37IJB/

The Dynare package should work after this fix.