Install Dynare and make it work for the user (non-admin)

Dear all,

I have a question about the installation of Dynare, and I am not sure where I should post it. The issue relates to installing Dynare and make it work as regular non-admin user.

The Matlab 2018b shows the following errors when starting, after installing Dynare as admin (the screenshot attached),

Dynare runs well with the admin account. I guess this relates to the issue with limited authority for regular users. This issue occurs when the administrator installing Dynare on the campus machine (for that I requested it). So I just post it here and see if there is going to be any luck.

Thank you!

How exactly did you install Dynare and what did you do that caused the error messages you show?

Dear Johannes,

How it happens is that the computer lab administrator installed Dynare as ‘administrator’ user on the campus machines, following the instructions in the manual. Things work great for the account with administrator right. Then after logging out the admin account and run a regular student account on the machine (which has limited authority to conduct certain operations on the machine), this is what happens when opening Matlab.

I heard that they (the campus tech staff) have dealt with it before (couple of years ago) and crank it through eventually. But seems like the person in charge is now a little confused. I guess it relates to limited authority for regular student account reading/writing certain files on the machine.

I don’t know if the description make things clearer.

Thank you,

Hi, from what I can see in the screenshots, I have the impression that is more a matlab installation related issue than a dynare installation issue. Is Matlab working for non Dynare related stuff?


Dear Stéphane,

That is a good point. The thing is that no error message is reported and everything works when logged in as an admin: Matlab 2018b works and Dynare works. Also, as the staff told me, this error appears after he attempted to install Dynare on the machine… Matlab 2018b was all good before the installation, as he said.

Of course, there could be a chance that something else breaks down and causing this issue at the meantime Dynare was installed, but I am not sure either is the case.

I think the staff is working on it now (not sure when he can fix it), and he asked me for help, so I posted the question here. Thanks for taking a look.


Hi, I do not see how the installation of Dynare could change anything to the Matlab installation… The error messages relate to Matlab functions (or java/Matlab) and permission issues. I do not have with the installation of Matlab on Windows servers, but the error messages clearly points to permission issues.


@stzfe Have you tried not installing Dynare via the installer, but rather simply using the zip-version at ? That should not affect Matlab. Also, where did you install Dynare to, i.e. which folder?

@stepan-a Is is intended that we only have zip files for the unstable version, but not the stable one?

@jpfeifer I do not see how the zip archive can help here, but it is available:

We only have it for 4.5.x, it was not produced before. There is no link to this folder, but we will add it when we upgrade the website.


@stepan-a I am puzzled by the error messages on toolbox\local and getInstalledSupportPackagesInfo. So maybe the IT team tried a weird way of installing Dynare as a Matlab App or something like this. With the zip-file, you can simply put the files in a folder where the local user has permissions and then you are good to go.

Dear Johannes and Stéphane,

Thank you for your suggestions. I am forwarding the posts to the IT personnel and will try to give feedback later on this issue.


I would need to check the folder with the admin later. But I guess it is installed in the default path (the university machine only has one C disk)