Install Dynare 4.6.4 for Octave on MacOS 10.11.6 El Capitan

Dear all,
I am completely new to the Dynare and Octave environment, so please be gentle.
I am trying to install Dynare and Octave on my MacBook Pro running MacOS 10.11.6. As far as I have read Dynare 4.6.4 requires at least MacOS 10.11 so this should be ok. Furthermore, on the Octave website it states as well that at least MacOS 10.11 is required. Hence, my MacBook should fulfill the minimum requirements.

I followed the installation process describe here https://www.dynare.org/resources/quick_start/.
Homebrew was already installed, however, to make sure everything is up to date I updated Homebrew first. Then, when typing in

brew install dynare

the following error shows up:

Warning: You are using macOS 10.11.
We (and Apple) do not provide support for this old version.
You will encounter build failures with some formulae.
Please create pull requests instead of asking for help on Homebrew's GitHub,
Twitter or any other official channels. You are responsible for resolving
any issues you experience while you are running this
old version.

qt@5: macOS Sierra or newer is required for this software.
Error: An unsatisfied requirement failed this build.

I understand the error message. It says that my system is too old. However, as a next step I tried to install only Octave by typing in

brew install octave

where I received exactly the same error as before.

Therefore, I concluded that the problem must lie in the installation of Octave. As a next step I installed Octave directly from https://octave-app.org. It installed just fine which it should since the minimum requirements are fulfilled. Hence, I do not understand the error message above since Octave should install without errors with the min. requirements fulfilled.
However, when I try to open it nothing happens.

Additionally, I downloaded the Dynare 4.6.4 pkg from https://www.dynare.org/download/ hoping that maybe in combination with Octave it somehow will work. However, during the installation process as soon as it said ‘less than one minute remaining’ nothing happened anymore for a long time and it seems that the installation process just stopped.

Now, I do not know where to continue…

Could someone please give some tips where to continue with solving this issue?

Thank you all in advance!

Hi,

To use Dynare 4.6.4 with Octave, you must use the Octave from Homebrew (it will not work with the Octave from https://octave-app.org).

Obviously, if you can’t install Octave through Homebrew, it means that a more recent version of macOS is required (and therefore the information on our website is wrong, at least when using Octave instead of MATLAB).

Actually the Dynare Team only has access to macs running the latest macOS (11, Big Sur). Other configurations are untested (i.e. they may or may not work, and in any case we cannot provide support). We should update our website.

Best,

S. Villemot

Please also note that, if you want to use Octave, you need to also install Dynare through Homebrew. Don’t use the macOS package that we distribute, it only works with MATLAB.

Thank you.

My problem was that the latest natively supported macOS on my device is macOS 10.11 El Capitan. However, there exist patched versions of more recent macOS which can be installed to solve this issue (just google the macOS version you would like to update to and append ‘patcher’). I did so and now everything runs smoothly. Obviously these patched versions are no official macOS but rather slightly modified to work with older devices.

So if someone else faces my problem it may be worth considering to install a more recent patched macOS.

Best,
Manuel

1 Like