Index bounds

Hi, I´m trying simulate a SOE DSGE model based on Gerali et al (2010), but it’s appearing the following error mensage:

??? Attempted to access y(75); index out of bounds because

Error in ==> simul_teseR2_static at 77
T522 = exp(y(38))*exp(y(75))/(exp(y(75))-1)/exp(y(37));

Error in ==> evaluate_static_model at 63
residuals = feval(fh_static,ys,exo_ss,params);

Error in ==> evaluate_steady_state_file at 96
[residuals,check] =

Error in ==> evaluate_steady_state at 58
[ys,params,info] =
evaluate_steady_state_file(ys_init,exo_ss,M, …

Error in ==> steady_ at 54
[steady_state,params,info] =
Error in ==> steady at 81
[steady_state,M_.params,info] = steady_(M_,options_,oo_);

Error in ==> simul_teseR2 at 900

Error in ==> dynare at 180
evalin(‘base’,fname) ;

Any ideas why this is happening and how can I fix this?

Best regards, Márcio.

This is most probably a bug. Please try the most recent unstable version and report back.

I tried the latest snapshot for windows (2015-03-03), but now another error message appears:

??? Undefined function or method
’cell2table’ for input arguments of type

Error in ==> global_initialization at 366
estimation_info.joint_parameter =

Error in ==> simul_teseR2 at 19

Error in ==> dynare at 185
evalin(‘base’,fname) ;

Sorry, but this is a bug introduced in yesterday’s unstable version related to a new feature being introduced. Please try the one of 2015-03-02

Hi, I tried the version 20015-02-03, but the first error message appears again. Can be something wrong with my script? Could you take a look please?
simul_teseR2.mod (26.5 KB)

I cannot replicate your issue. Are you using Octave or Matlab?

Rather, when increasing maxit, I can find a steady state, but model_diagnostics says

MODEL_DIAGNOSTICS: The Jacobian of the static model is singular MODEL_DIAGNOSTICS: there is 1 colinear relationships between the variables and the equations Colinear variables: debt_iw Colinear equations 49 50 51

I’m using matlab.

I’m using 2011’s version of matlab.

As I said, I cannot replicate the problem, which makes it hard to recommend anything. Please try the following: put the mod-file in a new, empty folder and run it again. When to problem pops up again, zip the whole folder and upload it please.


I ran the script in a empty folder and the bug didn't appear, seems that the error was caused by another file recorded in the folder.

Open economy.rar (26.1 KB)