Implementing ZLB failed perfect foresight solution when using lmmcp

Dear all,

I am trying to modify a model created by Eichenbaum, Rebelo and Trabandt “Epidemics in the new Keynesian model”.
The initial step I want to make is to add a ZLB into the model. I tried to use “lmmcp” algorithm to solve the model, however it failed to simulate the perfect foresight model and homotopy method did not work neither (after 1 hour of running, the behaviour seems explosive).
The only adjustment I made was to add [mcp=‘Rb>1’] and changed old Dynare command to the newest version (I changed simul and sim1 to perfect_foresight_solver).
Could anyone help me to find the problem from this?
Very appreciated. (1.2 MB)

Does the simulation work without the MCP-tag?

Hi Professor, thanks for the reply.

Yes the simulation works if I do not use the lmmcp algorithm (e.g., instead using simple stack_solve_algo=0). Simulation with stack_solve_algo=0 is the original version published by Eichenbaum et al., what I have changed is to add the ZLB by using the MCP tag.

If you mean just without the line [mcp=‘Rb>1’] and still using perfect_foresight_solver(lmmcp), then the answer is No. As long as the model is simulated with lmmcp the output says, “Simulation of the perfect foresight model failed! Switching to a homotopy method…” which at the end still fails.

From what I can see, this was already initially a challenging problem where the authors manually programmed a homotopy setup. I doubt that you can simply plug a ZLB into the problem and expect it to work.

Dear Professor,

many thanks for your reply. I agree with you regarding this point very much.

However, I encountered some other problems when I tried to modify the simulation. The content is not about the LMMCP anymore, due to the length and the size of the attachments, I have sent you the questions per E-Mail. It will be great, if you could have a look at those questions and give some further guidance.