How to specify periods in solving ramsey_policy

I am learning to use ramsey_policy command. I note that the resulting irfs has 40 periods by default. However, I want to look at longer periods. So I add “periods=100” as an option

ramsey_policy(planner_discount=0.95,instruments=(r), periods=100);

however, dynare reports error:

STOCH_SIMUL error: The horizon of simulation is shorter than the number of observations to be dropped. STOCH_SIMUL error: Either increase options_.periods or decrease options_.drop.
I am wondering if there’s any way that I can specify the periods when dynare do the ramsey policy optimization. I attached a simple NK model as an example.
nk_ramsey1.mod (696 Bytes)

The option you are looking for is

if you want to have 100 periods IRFs. The periods
options is for simulations used to compute moments.