GSA example ls2003.mod error (a BUG?)

Hello everyone.

I got the next problem:

After starting the ls2003.mod example from GSA demos in Dynare (Version 4.2.1) under Matlab 7.12 (R2011a) I get, with preceeding MC iteration 2048 “No solution could be found” lines, the following error message:

[quote]??? Undefined function or variable “T”.

Error in ==> stab_map_ at 306

Error in ==> dynare_sensitivity at 186
x0 = stab_map_(OutputDirectoryName);

Error in ==> ls2003 at 192

Error in ==> dynare at 132
evalin(‘base’,fname) ;[/quote]

I didn’t change anything in the mod-file and wonder whether it is kind of a bug. I assume that this example is supposed to work.

How could I solve this problem?
Other two example from the GSA demos don’t work, either.

Originally, my intention was it to learn how to conduct bi-dimensial determinacy regions graphs. Trying several times to conduct those on my models t, Dynare/Matlab delivered exactly the same error messages mentioned above. So I checked the demos with the same success. Thats why the suspicion of a bug.

Had anybody had the same problem? I couldn’t find any topics with that problem.

Hi, there have been several bugfixes in the GSA-toolbox since version 4.2.1. Have you tried the most recent unstable version?

Thanks you fror reply.
Actually, I don’t know. I downloaded Dynare and GSA max. 6 weekes ago. So, I supposed that they were up to date, but will try the unstable version.

I confirm that this problem is not present in the unstable version.

Note that in the unstable version (which will become Dynare 4.3 in the future), the GSA is now incorporated in the main Dynare tree. You no longer need to dowload it separately.

Hi there, I’m trying to run the identification command in the unstable 2011-9-23 and get the error that ??? Input argument “M_” is undefined.
Was there any change in the syntax to call the identification/GSA toolbox? Do I now need to run the estimation before I run the identification routines? Thanks

The unstable version is… unstable, by definition! Unless you need bleeding edge stuff, you should use the stable version.

Try to upgrade to the latest snapshot, your problem may be fixed.

Thank you for pointing to this. I will check.