Fs2000_particle.mod error

I tried to learn the second order estimation and run fs2000_particle.mod file(posted on the dynare test file of Github repository) in Dynare 5.2 version. I have errors below. Would you please explain why it doesn’t work? I also tried to run dsge_base2.mod, but it also didn’t work. The only files, first_spec.mod and first_spec_MCMC.mod, worked and provided the results. I revised the, file fs2000_particle.mod similar to the first_spec_MCMC.mod file but it didn’t work. How should I modify the fs2000_particle.mod file?

first_spec.mod (484 Bytes)
fs2000_particle.mod (1.9 KB)
first_spec_MCMC.mod (737 Bytes)
fsdat_simul.m (6.4 KB)

You did not declare endogenous variables after the estimation/calib_smoother command.

Estimation using a non linear filter!

Prior distribution for parameter rho has unbounded density!

ESTIMATION_CHECKS: There was an error in computing the likelihood for initial parameter values.
ESTIMATION_CHECKS: If this is not a problem with the setting of options (check the error message below),
ESTIMATION_CHECKS: you should try using the calibrated version of the model as starting values. To do
ESTIMATION_CHECKS: this, add an empty estimated_params_init-block with use_calibration option immediately before the estimation
ESTIMATION_CHECKS: command (and after the estimated_params-block so that it does not get overwritten):

Error using initial_estimation_checks (line 111)
initial_estimation_checks:: particle filtering requires measurement error on the observables

Error in initial_estimation_checks (line 111)
error(‘initial_estimation_checks:: %s requires measurement error on the observables’,disp_string)

Error in dynare_estimation_1 (line 159)
oo_ =

Error in dynare_estimation (line 118)

Error in fs2000_particle.driver (line 270)

Error in dynare (line 281)
evalin(‘base’,[fname ‘.driver’]);

The fs2000_particle.mod has been removed from the execution of the testsuite as it has not been maintained in 9 years.