Failure in running Dynare++


I have installed Dynare, and I am trying to run Dynare++ on the command prompt. However, when I enter:
dynare++ FILENAME.mod
I’m getting the following error:
Assertion failed: ((m_->valid == LIFE_MUTEX) && (m_->busy > 0)), file …/…/mingw-w64-libraries/winpthreads/src/mutex.c, line 45

I have no clue what to do. Does anybody have any clue on how to resolve this problem? I’ve done all the steps on another computer, and I’m able to successfully run Dynare++ on that computer, which means I am installing/running things correctly. For some reason, it doesn’t run on my laptop.

All suggestions are greatly appreciated!

Could you please provide the file and state which Dynare version and operating system you are using.

I am using example1.mod provided in the Dynare package:
C:\Program Files (x86)\dynare\4.5.0\examples\dynare++\example1.mod

To be more exact, I moved the file to another location and then ran the following code on cmd
dynare++ example1.mod

By the way, I did add the environmental variable path
C:\Program Files (x86)\dynare\4.5.0\dynare++

so that the operating system can locate dynare++.

I am using Dynare 4.5.0 for Windows. I am using Windows 10, if that’s what you’re asking.

Thank you so much for the help!

Okay, I think I’ve solved my problem…

It is now working. The only thing that (I think) I changed is the ordering of the list of environmental variables path. I moved up the path for dynare++ one notch (above miktex).

Anyway it seems like it’s working. I appreciate your help!

I’m sorry about the confusion, but I am back to being clueless again. I turn on my laptop again, and now it doesn’t work again, and I cannot figure out how to make it work. Could you provide any comments on the following message (same error message re-pasted for convenience):
Assertion failed: ((m_->valid == LIFE_MUTEX) && (m_->busy > 0)), file …/…/mingw-w64-libraries/winpthreads/src/mutex.c, line 45