Failed to solve

Dear Prof. Pfeifer,

I am interested in running my model for different values of a parameter ‘phiP’ (in the calibration.m file, line 43). For values of phiP between -5 and -15, I am getting the following error: ‘failed to solve perfect foresight model’. Can you please help me understand why I am getting this error and how to overcome this issue?

I have tried the other non-linear model solution methodologies that exist in Dynare (stack_solve_algo=0 to 8) that also work with the bytecode option but I haven’t been able to get it to solve the model.

In order to run the model, please do this from the run.m file. I have already set phiP to -5 in calibration so Dynare can generate the error message.

Many thanks in advance for your help. (601.3 KB)

Dear Prof. Pfeifer,

Have you had a chance to have a look into my query?

Many thanks

When I run the code I get a weird-looking solution. Attached are the saved resultstransition_results.mat (193.6 KB)

Many thanks Prof. Pfeifer.
Do you know why the results would look like this? Does this mean there is something wrong with the model?

Sorry, I don’t know. Maybe you should work with a smaller model that is more transparent.