Extended Path algorithm not working for order>0


I tried to run the extended path algorithm for order>0 and get an error message:

“Reference to non-existent field ‘IntegrationAlgorithm’.”

After reading the post linked below, I added " ep.IntegrationAlgorithm = 'Tensor-Gaussian-Quadrature';" into the code, but it’s then still complaining about pfm.Omega missing from the “setup_integration_nodes” code.

I also tried dowloading the most recent unstable version (Jan 2019), but then the code is complaining about max operator in my mod file. I’m running simulations of a model with ZLB.

Please provide the file.

Here is Smets and Wouters from your Github page where I added extended path code in the end and a lower bound to interest rate.

With Dynare 4.7 - There’s a problem with missing IntergrationAlgorithm and pfm.Omega thereafter

With latest unstable Dynare it does not work due to max operator.

SmetsWouters.mod (9.0 KB) usmodel_data.mat (13.1 KB) usmodel_shock_decomp_mode.mat (8.5 KB)

I can run that code above in the unstable version. It simply takes forever.

I changed the mod file above to include ZLB. It runs without ZLB. With ZLB it complains about the max operator in the latest unstable version

Then please provide that version.

I had changed the mod file above to the version with ZLB. Please have a look at that.

The error message is very explicit:

ERROR: you have declared your model ‘linear’ but you are using a function (max, min, abs, sign) or an operator (<, >, <=, >=, ==, !=) on an endogenous variable.





I see! Thanks, it runs fine now.