Estimation problem in Julia

Dear all,
I try to perform a simple exercise through Julia but I fail to make estimation. The error information is : type EstimatedParameters has no field symbols.
I do not understand what mistake I have. Here are my data and mod file. Thanks for your help very much!
dataset.csv (1.6 KB)
RBC.mod (1.3 KB)

1 Like

Dear Luce,

  • DynareJulia doesn’t support the old format of declaring estimated parameters with lower bound and upper bound (Sorry the documentation is mistaken, I will correct it)
    Note that you don’t need it as the natural boundaries for the Beta distribution is 0 and 1.
  • In dataset.csv you must specify the name of the observed variable in the header on the first line of the file

Just a remark, stoch_simul without option computes a second order approximation, but the estimation command estimates the linear approximation of the model

I attach my version of your files

RBCmj1.mod (1.2 KB)
dataset_mj.csv (1.6 KB)



Dear prof. Michel
Thanks for your help very much! I have tried to run your version. The program succed to make stochastic simulation, but still fail to make estimation. The error information is also: type EstimatedParameters has no field symbols. Maybe should I use any other package besides Dynare?
Thank you again! I sincerely appreciate the work from Dynare team for making mod file implemented in Julia.

Best Regards

Can you please check which version of Dynare.jl do you use? I tested the files above with version v0.9.5

I have now corrected the documentation concerning estimated_parameters.

Thank you! I have updated the package and it works.

So Dynare Julia support estimation? I was under the impression it is not supported yet, based on the list of the “Supported Dynare instructions” in the github page:
GitHub - DynareJulia/Dynare.jl: A Julia rewrite of Dynare: solving, simulating and estimating DSGE models.

Yeah! Please refer to this documentation.
Estimation · Dynare.jl (

1 Like

Thanks @Yaakov for reporting the inaccuracy. I fixed the README file

1 Like

Hi all,
I am having the same issue on Dynare v0.9.6.
stoch_simul works fine, but any estimated_params block yields the error “ERROR: LoadError: type EstimatedParameters has no field symbols”
This is in a mod file that worked fine on Matlab.

Could you please share you the *.mod file and the entire log?

Thank you for your response Michel. Restarting Julia seems to have made the problem go away. The .mod file seems to be running fine now.

Yes, indeed. It is often necessary to restart Julia after updating for loading the last version of the package.

1 Like