Error using Dynare while running examples with Octave

After installation, I try to run Dynare´s examples and find the very same error message, no matter which mod file I try (DGGES : parameter number 19 is invalid / error: Fortran procedure terminated by call to XERBLA  more details below).

I am using Windows 10, Dynare 4.6.4 and Octave 6.2.0. But I have also tried with different versions of both Octave and Dynare (not exhaustively), but the error message is the same. Interestingly, I am able to run Dynare and Octave just fine in my personal notebook, which suggests me it might be some access/compatibility issue.

Any clues of what it might be?

dynare example1.mod
Using 64-bit preprocessor
Starting Dynare (version 4.6.4).
Calling Dynare with arguments: none
Starting preprocessing of the model file …
Found 6 equation(s).
Evaluating expressions…done
Computing static model derivatives (order 1).
Computing dynamic model derivatives (order 2).
Processing outputs …
Preprocessing completed.
DGGES : parameter number 19 is invalid
error: Fortran procedure terminated by call to XERBLA

error: called from
dyn_first_order_solver at line 190 column 46
stochastic_solvers at line 262 column 19
resol at line 120 column 15
stoch_simul at line 96 column 30
driver at line 211 column 27
dynare at line 293 column 1

Thanks in advance.


Dynare 4.6.4 only supports Octave 6.2:

Thanks for the prompt response. Just to be clear: I indeed used the Dynare 4.6.4 + Octave 6.2.0. However, I managed to make it work by using Dynare 4.6.3 and Octave 5.2.0. While installing the second, I selected the “Reference BLAS” library instead of “Open BLAS” one. It is not clear to me if other user have faced the same issue or if it is indeed something relevant. Anyway, just felt like I should share.

Me too. I’m just getting started and had to install the older Octave (6.3.0 being the current version). Anyways, that didn’t work.

The current unstable version/4.7 works with Octave 6.3

1 Like

Thanks Johannes. I’ll leave the solution that I found and is currently working for me, in case somebody else comes up with the same problem in the future:

I uninstalled/installed GNU Octave 6.2.0. This time, though, I did as dsinigaglia, selecting “Reference BLAS” instead of “Open BLAS”.

This option is available at some point during the installation process, so beware not to skip it. I really have no clue of why it works, but it did.

@ocarreon What was the output of
version -blas
in your Octave? There seem to be issues in Octave for some kernels

What it was with the previous installation, I don’t know. Right now, it returns:

ans = unknown or reference BLAS

I hope I understood your question.