Error running dynare

I have problems running this mod file with dynare version 4.3.
I found the part of the code from line 57 to line 99 in another mod file and i simply add this portion of the code to my basic RBC model (a quite standard one).
This part of the code is nice because i could get same steady state results on my command window.
The fact is that when i run the code for the first time i get the following message

"??? Undefined function or method ‘RBC1_steadystate’ for input arguments of type ‘double’.

Error in ==> evaluate_steady_state_file at 49
[ys,check] = h_steadystate(ys_init, exo_ss);

Error in ==> evaluate_steady_state at 58
[ys,params,info] = evaluate_steady_state_file(ys_init,exo_ss,M, …

Error in ==> steady_ at 54
[steady_state,params,info] =
Error in ==> steady at 81
[steady_state,M_.params,info] = steady_(M_,options_,oo_);

Error in ==> RBC1 at 137

Error in ==> dynare at 120
evalin(‘base’,fname) ; "

When i run the file a second time , WITHOUT changing anything , all seems fine.
This only happen with the latest version of dynare (4.3) while everything worked well with the previous one. (besides, with the previous version line 59 was active and worked well).

Any possible explanation?
thanks for your reply.
write_ss_on_dynarefile.m (858 Bytes)
RBC1.mod (2.72 KB)