Error message: Dynare

I’m using Dynare 4.5.6 with Octave 4.4.0. Having problem running Dynare built-in examples. I get the following message. Any help will be appreciated.

error: Invalid call to beta. Correct usage is:

– beta (A, B)
error: called from
print_usage at line 91 column 5
beta at line 51 column 5
example3_steady_state_helper>@ at line 3 column 15
fsolve at line 204 column 8
example3_steady_state_helper at line 3 column 2

This is strange and looks like a bug in Octave. For some reason, the program does not recognize that beta is the name of a function input and tries to call its built-in function. Do other example work?

Thanks for your response. I think you might be correct that there could be bug in Octave. I tried again running the examples after I correctly defined the path and directory and some run and some don’t. When I try to run Example1 and 2 the program exits. Been able to run ramst only successfully. I am running the above in GUI interface. I can’t run NK_baseline example in GUI but it runs fine in CLI.
I get the following message now when I run the example3_steady-state_helper (same error in GUI & CLI):

addpath c:\dynare\4.5.6\matlab

cd c:\dynare\4.5.6\examples

dynare example3_steady_state_helper
warning: function C:\Octave\OCTAVE~1.0\share\octave\packages\statistics-1.3.0\mad.m shadows a cor
e library function
warning: called from
load_packages_and_dependencies at line 48 column 5
load_packages at line 47 column 3
pkg at line 457 column 7
user_has_octave_forge_package at line 27 column 9
dynare_config at line 102 column 1
dynare at line 63 column 12

Configuring Dynare …
[mex] Generalized QZ.
[mex] Sylvester equation solution.
[mex] Kronecker products.
[mex] Sparse kronecker products.
[mex] Local state space iteration (second order).
[mex] Bytecode evaluation.
[mex] k-order perturbation solver.
[mex] k-order solution simulation.
[mex] Quasi Monte-Carlo sequence (Sobol).
[mex] Markov Switching SBVAR.

Using 64-bit preprocessor
Starting Dynare (version 4.5.6).
Starting preprocessing of the model file …
ERROR: example3_steady_state_helper.mod: line 7, cols 1-0: syntax error, unexpected $end

error: DYNARE: preprocessing failed
error: called from
dynare at line 229 column 5

@sebastien Can you reproduce this problem on Linux?

I can’t replicate the problem on Octave 4.4.

My impression is that the problem comes from an outdated installation of Octave add-ons, especially the statistics package which seems out-of-date.

@Abid: what is the output of pkg list in Octave?

Can you try to run pkg update to see if it fixes the problem?