Error in Variance Decomposition

Hi there,

I am trying to simulate a small open economy RBC model with terms of trade, productivity and government spending shocks. The government finances it’s spending in the form of a simple time invariant proportional tax on both labour and capital income. There is no government debt or lump sum taxes in the government’s budget constraint.

Anyways, the stochastic (three) disturbances follow a simple AR(1) process and I assume that there is no correlation among the shocks. My query is when I try to run the model, the total variance decomposition adds up to more than 100! I am getting the following message: “Note: numbers do not add up to 100 due to non-zero correlation of simulated shocks in small samples”

I would appreciate any help on this.

P.S. I am using Dynare v 4.5.1



What you describe is normal, because you are conducting a simulated variance decomposition. If you use a theoretical one (periods=0), the numbers will add up to 100

1 Like

Hi Johannes,

Thank you very much for your response. It worked! Also, I am not sure what the syntax period not equal to zero means in terms of computing the variance decomposition? What if I want to set the period length equal to the time series observations I actually have?


The variance decomposition is a theoretical property, relying on shocks being orthogonal. If periods>0, something similar is done via simulating the model with one shock at a time. As the random shocks generated by the random number generator will always have some small correlation in finite samples, the numbers will then not add up to 100.

Thanks Johannes. It makes sense now. I guess there is no point in including periods greater than zero then.

Hi I am having the same issue with the variance decomposition not adding up to 100. I tried to set periods=0 but I can’t see anything such variance or moments printed. I mean no variance decomposition is performed for the endogenous with respect to the exogenous shocks in the system. I wonder whether I am using the command “periods” the wrong way.
Could anybody clarify how this command solve this issue.

That is strange, but without the mod-file it is impossible to tell what is going on.

When i make bayesian’ estimation,I met a problem that “Initial value of the log posterior (or likelihood): -3996767181.4319”,and then No posterior distribution map.

Without the files it is impossible to tell.