Erreur de compilation


Hello Professor, I tried with mode_compute=5
here is the message I get:
Warning: Matrix is close to singular or badly scaled. Results may be inaccurate. RCOND = 1.775049e-30.

In mr_hessian (line 220)
In newrat (line 260)
In dynare_minimize_objective (line 326)
In dynare_estimation_1 (line 214)
In dynare_estimation (line 118)
In salimDSGE.driver (line 519)
In dynare (line 281)

salimDSGE.mod (11.0 KB)

Did you fix your data treatment?

how should i correct the data processing?

You need to deal with the trend. I provided you with a detailed reference on how that may be done.

without lying to you I have read and tried to understand but in vain.
try to correct the errors in my mod file please

Let me reiterate my main point

I don’t have the time or resources to function as your advisor as I have my own students to supervise and there are simply too many requests for help in this forum and my inbox. At this point, I already replied to you more than 30 times. That’s not sustainable.

good evening professor, I would like to inform you that my model was able to run, however I have a problem with the variance decomposition, please take a look at the figure and how to correct it so that the var exo can all appear on the graph instead of e_G only
untitled.fig (65.2 KB)

You still did not fix the data treatment issue. That causes the strange graph. Because the mean is still present, the initial condition needs to explain most of the data.

yes I understood the problem thank you very much

I would like to know how to publish an article under dynare ?

thank you very much Professor Johaness,

What do you mean with


the paper I wrote on budget policy for Niger using Bayesian estimation of the DSGE model

good evening professor Pfeifer
look at what the post mean values and the confidence interval give at the level of e_m
how to correct this major problem?

Capture d’écran 2023-04-01 181848

Yes, that looks rather strange.

you see? how can we fix it?

Pretty much anything. Without tedious debugging, it is impossible to tell.

I can’t understand it too, it’s not a matlab bug?

that’s why I have decomposition graphs that are most often marked by the variable e_m

It’s almost always the user, not the program. Did you fix the observation equations?

I believe that everything is corrected
you can check
salimDSGE.mod (11.2 KB)